View Single Post
  #6   (View Single Post)  
Old 27th July 2008
co_bofh co_bofh is offline
New User
Join Date: Jul 2008
Posts: 8

Originally Posted by ai-danno View Post
A few things-

Most people here will tell you that you are working with an older version of OBSD which is no longer officially supported. 4.3 is out, and 4.4 is around the corner.
Appreciate that. The ISP I'm using prebuilds systems and 4.0 is the newest version they have available.

Also, is the path being designated in the error message actually real? Does actually live there, or could it be somewhere else? I know that sounds like a stupid question, but I've done this before.
Don't worry about the questions Yes, the path exists and is readable as the mysql and curl libraries load without a problem.

Also, from what I can remember, until recently, rrdtool was 1.049 for quite awhile (as in the standard version for most releases of OBSD of late.) So when you say you loaded an older version, what version was that?
1.0.49 is the version I rolled back to. There's a 1.3.1 version but it's replace one of the libraries with cairo which is what I was having problems installing.

I can say with certainty that I had all of this working when I ran 4.0 - it was used for a Cacti installation (which ran, but was really really slow.) But coming full circle, instead of beating your head against a wall on this, you may want to install a newer version of OBSD. The nice thing about this solution is that the newer version of rrdtool is included as a package (1.2), and the quality of the graphics is vastly improved over 1.049 (or whatever earlier version you are using.)
Unfortunately my options are limited there. I'm moving from a 3.9 install that was working without a problem to 4.0.

And to answer the next question, I have xbase40, xfont40, xserv40 and xshare40 installed and did use the -p flag

I just tried to create php from source and include the gd library on the command line and am getting a failure during configure. It finds the libraries:

checking for GD support... yes
checking for the location of libjpeg... /usr/local
checking for the location of libpng... /usr/local
checking for the location of libXpm... no
checking for FreeType 1.x support... no
checking for FreeType 2... /usr/local
checking for T1lib support... no
checking whether to enable truetype string function in GD... no
checking whether to enable JIS-mapped Japanese font support in GD... no
checking for jpeg_read_header in -ljpeg... yes
checking for png_write_image in -lpng... yes
If configure fails try --with-xpm-dir=<DIR>
checking for FT_New_Face in -lfreetype... yes
checking for gdImageString16 in -lgd... no
int main() {
; return 0; }
configure:42954: gcc -c -g -O2 -I/usr/local/include conftest.c 1>&5
configure: In function `main':
configure:42949: warning: assignment makes pointer from integer without a cast
configure:43436: checking for gdImageCreate in -lgd
configure:43455: gcc -o conftest -g -O2  -L/usr/local/lib  -L/usr/local/lib conftest.c -lgd  -lgd -lfreetype -lpng -lz -ljpeg -lssl -lcrypto -lz -lssl -lcrypto -lm  -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm 1>&5
/usr/local/lib/ warning: strcpy() is almost always misused, please use strlcpy()
/usr/local/lib/ warning: sprintf() is often misused, please use snprintf()
/usr/local/lib/ warning: strcat() is almost always misused, please use strlcat()
/usr/local/lib/ undefined reference to `pthread_mutex_unlock'
/usr/local/lib/ undefined reference to `pthread_mutex_destroy'
/usr/local/lib/ undefined reference to `pthread_mutex_lock'
/usr/local/lib/ undefined reference to `pthread_mutex_init'
collect2: ld returned 1 exit status
configure: failed program was:
#line 43444 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageCreate();

int main() {
; return 0; }
So I'm wondering if I still have an unresolved problem with gd that didn't pop up during the configure/make/install.

Thanks for the answers though.

Reply With Quote