View Single Post
  #1   (View Single Post)  
Old 3rd January 2010
Mantazz Mantazz is offline
Shell Scout
Join Date: Oct 2008
Posts: 90
Default Lost battery status in KDE4, FBSD 7.2-release

My FBSD 7.2 laptop is no longer displaying battery status in KDE4. I am certain it worked prior to December 22nd. The battery status is no longer displayed, and when I check power management I see
ConsoleKit was not found active on your PC, or PowerDevil cannot contact it.  ConsoleKit lets PowerDevil detect whether the current session is active, which is useful if you have more than one user logged into your system at any one time
The first thing I tried after seeing this was to update the ConsoleKit port. I had to update glib20 in order to do this, but was able to do that without a problem. However that did not solve the problem.
I saw some indications that ConsoleKit (and/or PowerDevil) is dependent on /proc; and since this is my laptop the security risks of mounting /proc are acceptable to me. I mounted proc through /etc/fstab. This also did not solve the problem.
I have not been able to find a way to update PowerDevil. Is it part of KDE4? I am contemplating updating KDE4 next if I can't find any other clear answer.
I think I last cvsup'ed my ports tree on Nov 30.
Reply With Quote