View Single Post
  #1   (View Single Post)  
Old 11th May 2019
rdikarlus rdikarlus is offline
Real Name: Carlosn
Port Guard
 
Join Date: Nov 2018
Location: IBZ ISLAND
Posts: 30
Default VLC media player installation

I am using OpenBSD 6.5 release. I can't install VLC media player due to missing dependencies. Here's the output:

# pkg_add vlc
quirks-3.142 signed on 2019-05-07T18:36:32Z
vlc-2.2.8p4:taglib-1.11.1p1: ok
vlc-2.2.8p4:libdvdcss-1.4.2p0: ok
vlc-2.2.8p4:libdvdread-6.0.1: ok
vlc-2.2.8p4:libidn-1.35: ok
vlc-2.2.8p4:sdl-1.2.15p10: ok
vlc-2.2.8p4:sdl-image-1.2.12p4: ok
vlc-2.2.8p4:libebml-1.3.7: ok
vlc-2.2.8p4:libmatroska-1.5.0p0: ok
vlc-2.2.8p4:x264-20180908p0: ok
vlc-2.2.8p4:x265-3.0: ok
vlc-2.2.8p4:lame-3.100p1: ok
vlc-2.2.8p4:dav1d-0.3.0p0: ok
vlc-2.2.8p4:libvpx-1.8.0v0: ok
vlc-2.2.8p4:xvidcore-1.3.4: ok
vlc-2.2.8p4:speex-1.2.0: ok
vlc-2.2.8p4:gsm-1.0.18: ok
vlc-2.2.8p4:ffmpeg-4.1.3v0: ok
vlc-2.2.8p4:libdvbpsi-1.3.1: ok
vlc-2.2.8p4:libcddb-1.3.2p0: ok
vlc-2.2.8p4:libbluray-1.0.0p0: ok
vlc-2.2.8p4:libdvdnav-6.0.0v0: ok
vlc-2.2.8p4:libtar-1.2.20: ok
Can't install vlc-2.2.8p4 because of libraries
|library drm.7.7 not found
| /usr/X11R6/lib/libdrm.so.7.6 (system): minor is too small
Direct dependencies for vlc-2.2.8p4 resolve to libdvbpsi-1.3.1 libgcrypt-1.8.4p0 libv4l-1.16.6 libvorbis-1.3.6 sdl-1.2.15p10 fribidi-1.0.5 gettext-0.19.8.1p3 libass-0.13.7p0 libidn-1.35 x265-3.0 qt4-4.8.7p19 libmatroska-1.5.0p0 taglib-1.11.1p1 libdvdnav-6.0.0v0 libnotify-0.7.8 sdl-image-1.2.12p4 gtk+2-2.24.32p2 libtar-1.2.20 libbluray-1.0.0p0 speex-1.2.0 png-1.6.37 gtk-update-icon-cache-3.24.8 desktop-file-utils-0.23p10 libsamplerate-0.1.9 dbus-1.12.12v0 libdvdread-6.0.1 x264-20180908p0 ffmpeg-4.1.3v0 libcddb-1.3.2p0 gnutls-3.6.7p0 opus-1.3.1 libxml-2.9.8p1 libebml-1.3.7
Full dependency tree is gcr-3.28.1p0 taglib-1.11.1p1 p11-kit-0.23.15p0 gettext-0.19.8.1p3 jasper-2.0.14 libdvbpsi-1.3.1 gnome-icon-theme-symbolic-3.12.0p3 sdl-1.2.15p10 bzip2-1.0.6p9 gtk+3-3.24.8 graphite2-1.3.13p0 speexdsp-1.2rc3 libunbound-1.9.1 at-spi2-atk-2.32.0 flac-1.3.2p2 libdaemon-0.14p1 shared-mime-info-1.10p5 libtheora-1.1.1p4 lame-3.100p1 gnutls-3.6.7p0 cdparanoia-3.a9.8p4 libsamplerate-0.1.9 adwaita-icon-theme-3.32.0 python-3.7.3p0 libcroco-0.6.13 pcre-8.41p2 libffi-3.2.1p5 libdvdcss-1.4.2p0 gsm-1.0.18 pinentry-1.1.0p0 gtk+2-2.24.32p2 libogg-1.3.3 libarchive-3.3.3 lz4-1.9.1 libdvdnav-6.0.0v0 glib2-networking-2.60.2 libusb1-1.0.21p1 dav1d-0.3.0p0 libexecinfo-0.3p1v0 x265-3.0 sdl2-2.0.9p0 libnettle-3.4.1p0 gsettings-desktop-schemas-3.32.0 libiconv-1.14p3 libv4l-1.16.6 gnome-icon-theme-3.12.0p5 libwebp-1.0.0 libebml-1.3.7 libcddb-1.3.2p0 icu4c-63.1 libdvdread-6.0.1 pango-1.42.4p1 cairo-1.16.0 atk-2.32.0 desktop-file-utils-0.23p10 libvpx-1.8.0v0 zstd-1.4.0 iso-codes-4.2p0 libnotify-0.7.8 at-spi2-core-2.32.1 libsecret-0.18.8p0 libtar-1.2.20 lcms-1.19 dbus-daemon-launch-helper-1.12.12 libass-0.13.7p0 libproxy-0.4.15p3 qt4-4.8.7p19 hicolor-icon-theme-0.17 lzo2-2.10p0 libvorbis-1.3.6 libxml-2.9.8p1 xz-5.2.4 libunistring-0.9.7 libassuan-2.5.1p0 opus-1.3.1 orc-0.4.29 sqlite3-3.27.2p0 dconf-0.32.0p0 gnupg-2.2.12 libbluray-1.0.0p0 gtk-update-icon-cache-3.24.8 librsvg-2.44.13 sdl-image-1.2.12p4 gdk-pixbuf-2.38.1 glib2-2.60.2 libmatroska-1.5.0p0 libsoup-2.66.1p0 libpsl-0.20.2 xvidcore-1.3.4 libidn-1.35 libgcrypt-1.8.4p0 avahi-0.7p6 harfbuzz-2.4.0 fribidi-1.0.5 libsndfile-1.0.28 libmng-1.0.10p3 libtasn1-4.13p0 gstreamer-plugins-base-0.10.36p19 giflib-5.1.6 tiff-4.0.10 npth-1.6 gdbm-1.16 dbus-1.12.12v0 ffmpeg-4.1.3v0 gvfs-1.40.1 libidn2-2.0.0p0 x264-20180908p0 libgpg-error-1.36 libksba-1.3.5p1 speex-1.2.0 gmp-6.1.2p3 gstreamer-0.10.36p12 png-1.6.37 jpeg-2.0.2v0
New and changed readme(s):
/usr/local/share/doc/pkg-readmes/ffmpeg
Couldn't install vlc-2.2.8p4



My /etc/installurl file looks lije this

https://ftp.spline.de/pub/OpenBSD
#https://cdn.openbsd.org/pub/OpenBSD


Any idea how to solve these dependencies?

Thanks
Reply With Quote