Thread: USB flash drive
View Single Post
  #1   (View Single Post)  
Old 24th July 2008
criglerj's Avatar
criglerj criglerj is offline
Real Name: Jim Crigler
New User
Join Date: Jun 2008
Location: suburban Atlanta
Posts: 2
Default USB flash drive

I'm attempting to copy some photos from a USB flash "thumb" drive using my five year old Toshiba notebook (1905-S301) on NetBSD 4.0 using the GENERIC LAPTOP kernel. disklabel tells me to use /dev/sd0e, so I mount it with "mount -t msdos /dev/sd0e ~/floppy", then try to copy files with "cp -p ~/floppy/*.JPG .", and I get these messages on the console log:
umass0 at uhub1 port 2 configuration 1 interface 0
umass0: USB 2.0 Flash Disk, rev 2.00/1.00, addr 2
umass0: using SCSI over Bulk-Only
scsibus0 at umass0: 2 targets, 1 lun per target
sd0 at scsibus0 target 0 lun 0: <USB 2.0, Flash Disk, 0.00> disk removable
sd0: 983 MB, 500 cyl, 8 head, 32 sec, 512 bytes/sect x 2015231 sectors
umass0: BBB reset failed, TIMEOUT
umass0: BBB bulk-in clear stall failed, TIMEOUT
umass0: BBB bulk-out clear stall failed, TIMEOUT
The last three lines repeat over and over, and a few files get copied (the number of files successfully copied varies), but it never completes. The process hangs; the light on the drive flashes as if it's doing something, then stops, then starts again, but few files get copied to the local directory.

Rooting around on various archives and forums, I found the advice to disable ehci/ohci, so I did that, but it did not change the result. (To do this, at the boot configuration prompt I typed "find usb" and three devices showed up: uhci, ehci, ohci. I typed "disable ehci", then "disable ohci", then "find usb" to confirm they were disabled, and finally "exit" to boot the system.)

Does anyone have an idea? Did I get any part of the procedure wrong?
Reply With Quote