View Single Post
  #1   (View Single Post)  
Old 10th April 2009
AncientDragonfly's Avatar
AncientDragonfly AncientDragonfly is offline
not quite new user
Join Date: Apr 2009
Posts: 25
Default System messed up, should I just reinstall?

I'm using Release 7, and unfortunately have not kept up with updates very well since installed in Nov. 2008. Before that, I was using 6.2, so I'm not totally new, but I'm new enough that I don't know all the ins and outs of getting out of problems.

I was intending to upgrade to, or do a fresh install of, 7.1 Release soon, but can't get to it for a couple of weeks at least. So I thought I better update some ports anyway.

I first got the message:

===>>> Port directory: /usr/ports/sysutils/fusefs-kmod
===>>> This port is marked IGNORE
===>>> requires the userland sources to be installed. Set SRC_BASE if it is not in /usr/src
And so dealt with that ok, but my next update had a problem with linux-glib2. This is where I think I screwed up! I entered make deinstall devel/linux-glib2 from /usr/ports/ thinking that since I was giving it the directory, that it would only deinstall linux-glib2. I think it actually deinstalled a whole bunch of stuff.

Honestly, since then, I have tried so many different things, I am not sure what state the box is in, except that I know if I shut down any of the programs I depend on daily (email, firefox, mrxvt, etc) that are currently running, they will not open again. TG for the UPS.

I seem to to have issues with anything that is linked to, because that is in a lot of the errors I get trying to deinstall/install/update the missing programs. I have about 40 things that depend on it, but it is gone. I was happy when tea installed without an error, but then when I tried to run it, I got
/libexec/ Shared object "" not found, required by ""
I am lost. I don't know what to do from here. I have googled myself into a maze I can't find my way out of. Do I need to deinstall the 40 things that depend on, and then reinstall them? Is the problem possibly deeper than that, and the true extent not surfaced for me yet? I was somewhat taken aback when I went to run nano and it wasn't on the system anymore! Fortunately it installed again without a hitch. Have I (stupidly) deleted all programs, not just X programs? Is it going to take longer to fix this than to just build a new system with 7.1, which I was hoping to do soon anyway?

Anyway, without further rambling, if anyone can help, I'd really appreciate it. I'd be glad to provide any information that will help someone help me fix this.
Reply With Quote