View Single Post
  #1   (View Single Post)  
Old 24th July 2008
sam-i-am sam-i-am is offline
New User
Join Date: Jul 2008
Posts: 2
Default problem applying patch

I run OpenBSD 4.2 release, and keep it up to date applying patches per the errata page. - 013: SECURITY FIX: July 23, 2008 2nd revision.

Attempting to apply the very important bind patch, I found it would not compile. So I reversed the patch, to check if the original version would compile. I even download the source again to check if a clean version would compile.

In both cases I get the same error:

cc  -I/usr/src/usr.sbin/bind/obj -I. -Iinclude -I/usr/src/usr.sbin/bind/obj/lib/dns/include  -I/usr/src/usr.sbin/bind/lib/dns/include  -I/usr/src/usr.sbin/bind/obj/lib/isc/include  -I/usr/src/usr.sbin/bind/lib/isc  -I/usr/src/usr.sbin/bind/lib/isc/include  -I/usr/src/usr.sbin/bind/lib/isc/unix/include  -I/usr/src/usr.sbin/bind/lib/isc/nothreads/include    -DUSE_MD5 -DOPENSSL  -O2 -pipe   -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -Wpointer-arith -fno-strict-aliasing  -c /usr/src/usr.sbin/bind/lib/dns/acl.c
In file included from /usr/src/usr.sbin/bind/lib/dns/include/dns/types.h:154,
                 from /usr/src/usr.sbin/bind/lib/dns/include/dns/name.h:82,
                 from /usr/src/usr.sbin/bind/lib/dns/include/dns/acl.h:40,
                 from /usr/src/usr.sbin/bind/lib/dns/acl.c:26:
include/dns/enumtype.h:77: error: redefinition of `dns_rdatatype_dlv'
include/dns/enumtype.h:76: error: `dns_rdatatype_dlv' previously defined here
*** Error code 1

Stop in /usr/src/usr.sbin/bind/obj/lib/dns.
*** Error code 1

Stop in /usr/src/usr.sbin/bind/obj/lib (line 99 of Makefile).
*** Error code 1

Stop in /usr/src/usr.sbin/bind/obj (line 97 of Makefile).
*** Error code 1

Stop in /usr/src/usr.sbin/bind (line 54 of /usr/src/usr.sbin/bind/Makefile.bsd-wrapper).
Indeed in /usr/obj/usr.sbin/bind/lib/dns/include/dns/enumtype.h, which is generated by the compile process, that data definition is there twice...

 ***************   DO NOT EDIT!
        dns_rdatatype_dlv = 32769,
        dns_rdatatype_dlv = 65323,
At that point I am stuck.

I don't know how to work out how the build process generates that file (athough make clean gets rid of it).
I don't know which value is correct, even if I do work out how that file gets generated.

I figure I am not the only person who has attempted to apply this patch, and I can't find any other reports of it on Google, so it's unlikely to be a general problem associated with the 'release' or 'stable' version, and is probably something specific to my systems' build options, which is causing this error. But what?

Thanks in advance if you can assist.

Reply With Quote