View Single Post
  #1   (View Single Post)  
Old 9th March 2009
Zmyrgel Zmyrgel is offline
Port Guard
Join Date: May 2008
Posts: 26
Default Screen + utf8 not working

I'm having problems with unicode on my OpenBSD.
I've installed the ROXTerm from the ports and set the keyboard encoding to UTF-8.
I tested it with emacs 'hello-page' (run with -nw) and it displays quite a lot of the languages correctly so utf-8 seems to work on emacs and on the terminal itself so everythings OK this far.

On terminal when I type ä it displays it correctly but when I delete it I have to delete two chars. I think this is the normal behavior as OpenBSD doesn't have OS-level unicode support yet.

Then to the problem. When I run GNU screen it breaks things. When I type ä inside screen it prints "a. Also, when I close the screen it still gives "a instead of ä.

I have given following options in .screenrc:
defutf8 on
utf8 on on
I also tried to start the screen with the -U switch but nothing seems to help me.

Any suggestions how to get the screen to behave properly?
Reply With Quote