View Single Post
  #4   (View Single Post)  
Old 10th January 2017
pygope pygope is offline
Port Guard
Join Date: Apr 2015
Posts: 33

Originally Posted by KenJackson View Post
Thank you. I was coming to that conclusion, but that doesn't seem to be a complete answer.

File /etc/rc.d/xdm has this line:

Apparently the directory in that and other files should be changed to "/usr/pkg/lib/xorg", but the "xdm" package I installed with pkgin doesn't modify or replace that file. It seems like it MUST be changed to get the modular version of xdm (/usr/pkg/bin/xdm) started at boot instead of the base version (/usr/X11R7/bin/xdm).

When I installed NetBSD, I selected a full installation from the menu instead of full minus X. So now how can I remove the base X files? A four-year old wiki page says to execute "pkg_delete -r x11-links", but that command returns:
pkg_delete: No matching package for basename `x11-links' of `x11-links'

I'm fumbling my way though the pkg_ commands looking for a way to show what the basename for X is and how I can uninstall it. I'm thinking of wiping the disk and reinstalling with the minus-X option, but that's time consuming with no guarantee it will work.

BTW, I like the "pkgin" command and the pre-compiled packages. But there remains a confusing mishmash of base and pkgsrc commands that are non-obviously orthogonal or mutually exclusive or redundant.
If you want to remove the complete X sets from installation, see this:
I used it some years ago, and worked for me.

Also you have to take into account that if you change your X packages from installation to modular with pkgsrc. You MUST install any X related package, as xdm, from pkgsrc instead from binary packages, because binary ones were created with the standard X from installation, that is the reason that xdm obtained from pkgin doesn't point to your X location.
Of course you have to keep the line X11_TYPE=modular in your /etc/mk.conf in order the built packages to work.
Reply With Quote