View Single Post
  #8   (View Single Post)  
Old 18th August 2012
thirdm thirdm is offline
Spam Deminer
 
Join Date: May 2009
Posts: 234
Default

Alright, it completed without problems on my system...
Code:
# pkg_info -R pcre
Information for pcre-8.30nb2:

Required by:
glib2-2.32.3nb1
libast-0.7nb7
xfce4-thunar-1.0.1nb10


# pkg_info -n xfce4
Information for xfce4-4.6.1nb13:

Requires:
glib2>=2.30.2nb3
gtk2+>=2.24.10nb1
libSM>=0.99.2
xfce4-mixer>=4.6.0
xfce4-mousepad>=0.2.16
gnome-icon-theme>=2.12.1nb2
xfce4-icon-theme>=4.4.3nb7
xfce4-print>=4.6.1nb8
xfce4-appfinder>=4.6.0
xfce4-thunar>=1.0.1nb10
xfce4-panel>=4.6.2nb9
xfce4-volman>=0.2.0nb2
xfce4-xarchiver>=0.5.2nb10
xfce4-orage>=4.6.0
xfce4-wm-themes>=4.6.0
xfce4-wm>=4.6.0
xfce4-desktop>=4.6.0
xfce4-gtk2-engine>=2.6.0
xfce4-session>=4.6.1nb8
xfce4-settings>=4.6.0
xfce4-terminal>=0.2.10
xfce4-utils>=4.6.0
All I can think is that you're trying to treat an upgrade situation like a normal fresh install situation (except where you hit trouble with pcre specifically). I'm not sure, but I think it may be best to use a tool like pkgchk or pkg_rolling-update to do updates of complicated packages. I mean, I guess it should work to do a pkg_delete -r on each package stopping your upgrade (assuming that's where you're at) and then do a normal make install to get the new versions, but that's tedious work.

Or maybe this isn't your situation at all. I don't have that many packages installed, so I may be missing a genuine conflict you're seeing:

# pkg_info -a | wc -l
458

Last edited by ocicat; 18th August 2012 at 04:18 PM. Reason: Please use [code] and [/code] tags when posting output.
Reply With Quote