View Single Post
  #4   (View Single Post)  
Old 1st March 2016
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,343
Default

If I recall correctly, hp-setup requires CUPS. You've built it. Is your cupsd daemon running?

While I use a different OS, I also have an HP printer on my network.
Code:
$ host printer
printer.jggimi.homeip.net has address 10.0.4.131
$ ping printer
PING printer.jggimi.homeip.net (10.0.4.131): 56 data bytes
64 bytes from 10.0.4.131: icmp_seq=0 ttl=254 time=3.562 ms
64 bytes from 10.0.4.131: icmp_seq=1 ttl=254 time=3.710 ms
64 bytes from 10.0.4.131: icmp_seq=2 ttl=254 time=5.306 ms
--- printer.jggimi.homeip.net ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 3.562/4.193/5.306/0.790 ms
$ hp-setup -i printer

HP Linux Imaging and Printing System (ver. 3.15.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)

Setting up device: hp:/net/HP_LaserJet_400_color_M451nw?hostname=printer


---------------------
| PRINT QUEUE SETUP |
---------------------

warning: One or more print queues already exist for this device: printer.

Would you like to install another print queue for this device (y=yes, n=no*, q=quit) ? 


Done.
$
Reply With Quote