View Single Post
  #4   (View Single Post)  
Old 2nd April 2013
thirdm thirdm is offline
Spam Deminer
Join Date: May 2009
Posts: 234

An update on this:

Over the weekend I tried building cwm with debugging information. Surprisingly when I installed that the problem went away. I then stripped the cwm binary and tried again. Still no problem. Now I'm thinking one of the following happened:

1. I didn't have the source I thought I did, so my debugging rebuild reverted to source before the bug appeared or after it was fixed.
1.1. The bug only appeared in the snapshot I'd taken (I gather snapshots sometimes include code, for testing purposes, that never reaches cvs) and doesn't exist in current. I thought that I had built from current after taking a february snapshot, but it's possible I missed a step in building/installing xenocara and really had the snapshot binary of cwm still. (Unfortunately I forgot to back up the old binary before overwriting it with the debugging one -- I'll try getting the snapshot binary out of the dist. tarball later if I can)
2. My environment is inconsistent or out of sync in some way and the bug is really only an artifact of that. (not consistent with you reproducing it)
3. There's a subtle timing issue involved that makes it an intermittent bug. Maybe running with debugging symbols skewed things to where it didn't happen. (not consistent with stripping having it still missing or that you could reproduce it)

I'm going away for a few days, but I'll try to dig into this next week to see what I did and if I can still reproduce the bug.

I'm kind of puzzled here but at least it going away when I rebuilt (only) cwm points to it (if it's real) being a cwm issue more likely than something wrong with emacs or Xorg in general.
Reply With Quote