Thread: Nagios issue
View Single Post
  #1   (View Single Post)  
Old 30th May 2008
scottro's Avatar
scottro scottro is offline
Real Name: Scott Robbins
ISO Quartermaster
Join Date: Apr 2008
Location: NYC
Posts: 625
Default Nagios issue

Well, since nagios is running on a CentOS server and the target machine is running Windows XP, a BSD forum is the best place to post.

We wanted to check time on some servers and workstations. There's a check_ntp_time plugin, which works, as near as I can see by looking at the code (but it's in C, so I could be wrong) by using NTP. The usual test for a nagios plugin, is to do something like (in the plugin directory) ./check_ntp_time -H <hostname>.

This is fine, I get a response.

However, when I define it as a nagios service, I get an email that the connection was refused. Googling hasn't given me an answer yet--I've seen one or two other people with a similar issue (different plugin, same pattern) but no solution.

There is a nagios client that can be run on Windows hosts. I put that client on one Windows host and that works.

However, since the ./check_plugin_name -H <host> worked, my hope was that I didn't have to install anything on the Windows machines.

If anyone knows nagios and has experienced this, I'd be grateful for any pointers. I was under the impression that if the ./check_plugin stuff from comand line worked, it would work with nagios.

I tried doing su - nagios and it still works from command line, so it doesn't seem to be a matter of different users.

Thanks for any pointers.
Reply With Quote