View Single Post
  #4   (View Single Post)  
Old 16th June 2008
KernelPanic KernelPanic is offline
Port Guard
Join Date: May 2008
Posts: 19

Originally Posted by stukov View Post
Worked for me. Have you tried updating the ports tree, cleaning work dir and rebuilding the port?
I deleted both the lang/php5 and the devel/php5-pcre port directories and retrieved them again via csup. I even reinstalled php5.2.6 thinking maybe something in the configs or the binary got messed up. I still get the same error.

It looks like this section of the lang/php5/Makefile is failing:

@${CAT} ${WRKSRC}/acinclude.m4 ${WRKSRC}/build/libtool.m4 > ${WRKSRC}/aclocal.m4

acinclude.m4, libtool.m4 and shtool are nowhere to be found in my work directory.

I extracted the source ball into /root/php-5.2.6 started copying files over that 'make' complained were missing:


At this point it appears the configure part works. But then libtool doesn't seem to be functioning properly:

===>  Building for php5-pcre-5.2.6
/bin/sh /usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/libtool --mode=compile cc -I/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/pcrelib -I. -I/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre -DPHP_ATOM_INC -I/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/include -I/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/main -I/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -O2 -fno-strict-aliasing -pipe   -c /usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/pcrelib/pcre_chartables.c -o pcrelib/pcre_chartables.lo
/usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/libtool: Can't open /usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre/libtool: No such file or directory
*** Error code 2

Stop in /usr/ports/devel/php5-pcre/work/php-5.2.6/ext/pcre.
*** Error code 1

Stop in /usr/ports/devel/php5-pcre.
I have no idea why the 'make' is looking for libtool the pcre work directory. At this point I'm ready to give up.

Last edited by KernelPanic; 16th June 2008 at 06:35 PM.
Reply With Quote