View Single Post
  #5   (View Single Post)  
Old 20th May 2008
fenrisW0lf fenrisW0lf is offline
Port Guard
Join Date: May 2008
Posts: 17

Thanks for the advice.

I ended up downloading the gcc3*.tgz files from the ftp site manually as I couldn't get a connection.

#ls -lh
total 47M
-rw-r--r--  1 root  wheel  1.3K May 20 07:12 gcc3-3.3.6.tgz
-rw-r--r--  1 root  wheel  2.4M May 20 07:13 gcc3-c++-3.3.6.tgz
-rw-r--r--  1 root  wheel  3.8M May 20 07:14 gcc3-c-3.3.6.tgz
-rw-r--r--  1 root  wheel  1.8M May 20 07:13 gcc3-f77-3.3.6.tgz
-rw-r--r--  1 root  wheel   37M May 20 07:14 gcc3-java-3.3.6.tgz
-rw-r--r--  1 root  wheel  1.3M May 20 07:14 gcc3-objc-3.3.6.tgz
Once the files were downloaded I used the pkg_add command and it indicated that some entries need to be made to the mk.conf file. I searched and don't have one on my system. I looked up some resources on the 'net but am unsure as how to configure it. Also there appears to be example mk.conf files but they are empty on my system.
#pkg_add gcc3-3.3.6.tgz

$NetBSD: MESSAGE,v 1.2 2003/07/08 15:04:58 drochner Exp $

To use gcc3-c++-3.3.6 include "/usr/pkg/gcc3/mk/" in your
BSD style makefile.


$NetBSD: MESSAGE,v 1.2 2003/07/08 15:05:00 drochner Exp $

To use gcc3-f77-3.3.6 include "/usr/pkg/gcc3/mk/" in your
BSD style makefile.

Here are the installed packages on my system (verifying that gcc3 was added):
# pkg_info -a
digest-20080510     Message digest wrapper utility
libtool-base-1.5.24nb5 Generic shared library support script (the script itself)
php-5.2.6           PHP Hypertext Preprocessor version 5
gmake-3.81          GNU version of 'make' utility
db4-4.6.21          Berkeley DB version 4 from Oracle
perl-5.8.8nb7       Practical Extraction and Report Language
pkg_install-20080423 Package management and administration tools for pkgsrc
unzip-5.52nb4       List, test and extract compressed files in a ZIP archive
readline-5.2nb1     GNU library that can recall and edit previous input
freetds-0.82        Implementation of TDS protocol used by Sybase and MS-SQL ser
m4-1.4.11nb1        GNU version of UNIX m4 macro language processor
autoconf-2.62       Generates automatic source code configuration scripts
mysql-client-5.0.51nb3 MySQL 5, a free SQL database (client)
mysql-server-5.0.51nb1 MySQL 5, a free SQL database (server)
automake-1.10.1     GNU Standards-compliant Makefile generator
libxml2-2.6.32      XML parser library from the GNOME project
php5-mysql-5.2.6    PHP extension for MySQL databases
expat-2.0.1         XML parser library written in C
libltdl-1.5.24      Generic shared library support (libltdl abstraction library)
xmlcatmgr-2.2nb1    XML and SGML catalog manager
php5-mbstring-5.2.6 PHP extension for multibyte characters support (currently, J
phpmyadmin- Set of PHP-scripts to adminstrate MySQL over the WWW
python24-2.4.5      Interpreted, interactive, object-oriented programming langua
unixodbc-2.2.12     ODBC 2.x/3.x driver manager
jpeg-6bnb4          IJG's jpeg compression utilities
py24-mysqldb-0.9.2nb3 MySQL interface for Python
apr-   Apache Portable Runtime
bison-2.3           GNU yacc(1) replacement
pkg_chk-1.92        Check installed package versions against pkgsrc
gcc3-c-3.3.6        GNU Compiler Collection, v3 - C compiler
gcc-2.95.3nb7       GNU Compiler Collection, version 2
gcc3-c++-3.3.6      GNU Compiler Collection, v3 - C++ compiler
gcc3-f77-3.3.6      GNU Compiler Collection, v3 - F77 compiler
gcc3-java-3.3.6     GNU Compiler Collection, v3 - Java compiler
gcc3-objc-3.3.6     GNU Compiler Collection, v3 - Objective C compiler
freetype2-2.3.5     Font rendering engine and library API
gcc3-3.3.6          GNU Compiler Collection, v3
tiff-3.8.2nb3       Library and tools for reading and writing TIFF data files
postfix-2.4.5       --- !ruby/object:RI::ClassDes
libmcrypt-2.5.8     Crypto algorithms library
mhash-0.9.9         Hash algorithms library
docbook-xml-4.4nb4  XML DTD designed for computer documentation
docbook-xsl-1.73.2nb1 Docbook XSL modular stylesheet
libgpg-error-1.4nb2 Definitions of common error values for all GnuPG components
csup-20070216       Rewrite of the CVSup file updating client in C
When I run pkg_chk -a -u -s -L /var/log/pkgchk.log I still get the error about not having a c++ compiler available. I can navigate to the package that is causing problems and run a make which yields the same error:
# cd /usr/pkgsrc/devel/gmp
# make
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/download-vulnerability-list'.
===> Configuring for gmp-4.2.2nb1
cd /usr/pkgsrc/devel/gmp/work/gmp-4.2.2 && type autoconf && autoconf
autoconf is /usr/pkgsrc/devel/gmp/work/.tools/bin/autoconf warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded from...
aclocal.m4:638: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:4926: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
aclocal.m4:2706: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:2705: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:86: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:66: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:31: AC_PROG_LIBTOOL is expanded from... the top level warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:683: AC_LIBTOOL_LINKER_OPTION is expanded from... warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:2783: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:2782: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:1831: _LT_AC_TAGCONFIG is expanded from... warning: AC_CACHE_VAL(lt_prog_compiler_static_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:4005: _LT_AC_LANG_F77_CONFIG is expanded from...
aclocal.m4:4004: AC_LIBTOOL_LANG_F77_CONFIG is expanded from... warning: AC_CACHE_VAL(lt_prog_compiler_static_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:4114: _LT_AC_LANG_GCJ_CONFIG is expanded from...
aclocal.m4:4113: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from... warning: AC_CACHE_VAL(lt_prog_compiler_static_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking build system type... i386-unknown-netbsdelf4.0
checking host system type... i386--netbsdelf
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for gawk... /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking for i386--netbsdelf-strip... no
checking for strip... strip
checking whether to enable maintainer-specific portions of Makefiles... no
checking ABI=32
checking whether cc is gcc... yes
checking compiler cc -O2 ... yes
checking compiler cc -O2 has sizeof(long)==4... yes
checking for i386--netbsdelf-gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for cc option to accept ISO C99... none needed
checking for cc option to accept ISO Standard C... (cached) none needed
checking how to run the C preprocessor... cc -E
checking build system compiler cc... yes
checking for build system preprocessor... cc -E
checking for build system executable suffix...
checking whether build system compiler is ANSI... yes
checking for build system compiler math library... -lm
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking C++ compiler c++  -O2... no, std iostream
configure: error: C++ compiler not available, see config.log for details
*** Error code 1

make: stopped in /usr/pkgsrc/devel/gmp
*** Error code 1

make: stopped in /usr/pkgsrc/devel/gmp
I am not sure how to proceed. I suspect that I need to create /etc/mk.conf and point it to the c++ compiler. I'll research this and try a few things.

Reply With Quote