View Single Post
  #1   (View Single Post)  
Old 8th July 2008
master-richie master-richie is offline
New User
Join Date: Jul 2008
Posts: 7
Default Tightvnc startup script not loading fonts - permission denied

am currently using the following script (usr/local/etc/rc.d/ I found somewhere on the web and modified (reduction) but still can't get vncserver to load on boot. it looks like it would work but it kicks out errors loading the default fonts - the fonts folders exist.

I applied chmod 755 to and set vnc_enable="YES" in rc.conf

# This script starts vncserver

. /etc/rc.subr


vncserver_options="-geometry 800x600 -compatiblekbd -fp '/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/'"


load_rc_config $name
eval "${rcvar}=\${${rcvar}:-'NO'}"
vnc_msg=${vnc_msg:-"Starting vncserver..."}

echo "$vnc_msg"
su [my user name in wheel group] -c "/usr/X11R6/bin/vncserver ${vncserver_display} ${vncserver_options}\

run_rc_command "$1"

have tried googling the error, changing single quotes to double quotes in my options string and manually typing the options on my su line - no luck.

am reaching out again for help .. once I can get vncserver loading during boot, I can install the server and will have all the time in the world to figure out the rest for myself. thanks in advance, ~Rich
Reply With Quote