View Single Post
  #2   (View Single Post)  
Old 3rd June 2019
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
Join Date: May 2008
Location: USA
Posts: 7,209

Originally Posted by braveheart View Post
I am new to the syntax of QEMU and would need a book to get me started.
There's the qemu(1) man page, links at, and several examples in the package README in /usr/local/share/doc/pkg-readmes/
Anyway the unmet dependency errors refer to Qt things, like:
Did you mean QPtrinter? QSessionManager? If so, all three of these, including QtWidgets, are part of the qtbase package. Please be sure to see the pkg_info(1) description for qtbase, as it describes changes you must make when building Qt applications outside of the Ports tree.
Thats all I can remember and retrieve anyway because I accidentally pulled the power cord out and the battery doesn't connect anymore (its flat and needs a new one). So the HDD [non-SSD] crashed, and OpenBSD cannot repair it, it stalls after trying to eventually.
Are you trying to tell us that manually issuing # fsck(8) <some mount point> fails to function? If so, it is possible to have insufficient RAM available if you have very large file systems, but then fsck will error out. Or, it is possible that an fsck(8) will take a very long time on a very large filesystem.
But that didn't immediately happen, it was after I installed a whole unrelated qt-(stuff), with examples, and the LXQT desktop environment thinking it would have the dependencies. But I tried again and it didn't work. Still the same errors.
Which errors? Missing libraries? Missing headers? Or fsck(8) errors?

This guidance for problem reporting may help:
Reply With Quote