View Single Post
  #4   (View Single Post)  
Old 8th September 2009
IdOp's Avatar
IdOp IdOp is offline
Too dumb for a smartphone
 
Join Date: May 2008
Location: twisting on the daemon's fork(2)
Posts: 828
Default

As far as I know, the 5.0 packages should still work with 5.0.1, they do for me. The pkg_add problem you're having also seems strange; when I do it I get a warning about the different versions, but it still proceeds with the addition. For example:

Code:
# echo $PKG_PATH
.;/mnt/samsung/usr/local/src/NetBSD/5.0/packages;ftp://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/i386/5.0/All

# pkg_add -v abcde-2.3.3nb2    
pkg_add: Warning: package `abcde-2.3.3nb2' was built for a platform:
pkg_add: NetBSD/i386 5.0 (pkg) vs. NetBSD/i386 5.0.1 (this host)
pkg_add: Warning: package `cd-discid-0.9' was built for a platform:
pkg_add: NetBSD/i386 5.0 (pkg) vs. NetBSD/i386 5.0.1 (this host)
bin/cd-discid
man/man1/cd-discid.1
Package cd-discid-0.9 registered in /var/db/pkg/cd-discid-0.9
pkg_add: Warning: package `id3-0.15' was built for a platform:
pkg_add: NetBSD/i386 5.0 (pkg) vs. NetBSD/i386 5.0.1 (this host)
bin/id3
man/man1/id3.1
Package id3-0.15 registered in /var/db/pkg/id3-0.15
pkg_add: Warning: package `id3v2-0.1.11nb2' was built for a platform:
pkg_add: NetBSD/i386 5.0 (pkg) vs. NetBSD/i386 5.0.1 (this host)
pkg_add: Warning: package `id3lib-3.8.3nb4' was built for a platform:
pkg_add: NetBSD/i386 5.0 (pkg) vs. NetBSD/i386 5.0.1 (this host)
bin/id3convert
bin/id3

...
Not sure what to suggest at the moment.
Reply With Quote