View Single Post
  #1   (View Single Post)  
Old 22nd August 2008
jsadm jsadm is offline
New User
Join Date: Aug 2008
Posts: 3
Default inetd, ftpd problems

I'm having issues with inetd/ftpd on a FreeBSD 5.1 server. Apparently any time the server is rebooted, the inetd process starts, as it's running on the process list and there's an file in /var/run. However, ftp connections are not accepted, and I then have to start ftpd manually.

Here is a portion of my rc.conf file (the lines after all the ipconfig lines and other network settings):

inetd_enable="YES" # Run the network daemon dispatcher (YES/NO).

All lines in my inetd.conf file are commented out other than these two:

ftp stream tcp nowait root /usr/libexec/ftpd ftpd -l
ftp stream tcp6 nowait root /usr/libexec/ftpd ftpd -l

First off, did I properly enable my server to accept ftp connections? Every installation guide I've seen basically said enabling inetd and uncommenting those lines in inetd.conf would do it, but that's not the case in my experience so far.

Secondly, I'm not beholden to using the BSD ftp, but it's simple and basically all I need it to do is chroot users to their home directories. If anyone has any suggestions on another ftp daemon that's decent, I'm open to using it.

Reply With Quote