View Single Post
  #1   (View Single Post)  
Old 16th February 2017
cag cag is offline
Real Name: Cág
Warrior from ports
Join Date: Feb 2017
Posts: 4
Question Segfaults in multiple programmes

Hi everyone,

I finally registered, have been reading the forum for years.

I'll simply copy this from LQ. Already have written to a couple of lists (including netbsd-users) but without results.

Running 7.0.2 with out of the box kernel. All my GTK+2 apps segfault on keyboard input. lxappearance for example, when looking for a theme you can start pressing keys and it will search. But in my case it dumps core with /usr/lib/, /usr/lib/ and /usr/pkg/lib/ The same thing happens when typing something into a GTK+2 text editor, leafpad, or looking for something in Ctrl+O window in firefox or gimp or any other programme. gimp can't even run inside gdb because of:
Program received signal SIGTRAP, Trace/breakpoint trap.
0x00007f7fea49f6aa in ___lwp_park60 () from /usr/lib/
(gdb) bt
#0  0x00007f7fea49f6aa in ___lwp_park60 () from /usr/lib/
#1  0x00007f7fec808f2b in pthread_cond_timedwait () from /usr/lib/
#2  0x00007f7feb880b80 in g_cond_wait () from /usr/pkg/lib/
#3  0x00007f7feb81d7cd in g_async_queue_pop_intern_unlocked () from /usr/pkg/lib/
#4  0x00007f7feb86742f in g_thread_pool_thread_proxy () from /usr/pkg/lib/
#5  0x00007f7feb866a7d in g_thread_proxy () from /usr/pkg/lib/
#6  0x00007f7fec80a9cc in ?? () from /usr/lib/
#7  0x00007f7fea483de0 in ?? () from /usr/lib/
#8  0x0000000000000000 in ?? ()
Firefox also has problems in and but doesn't say about __lwp_park60. It also can't run inside gdb.

lxappearance also dumps core when clicking Apply after changing something (themes, cursor or icon themes, fonts etc.) with another output:
#0  0x00007f7fefcb27ba in ?? () from /usr/lib/
#1  0x00007f7fefcb2bc7 in malloc () from /usr/lib/
#2  0x00007f7ff1849782 in g_malloc () from /usr/pkg/lib/
#3  0x00007f7ff185ef1c in g_memdup () from /usr/pkg/lib/
#4  0x00007f7ff18356b8 in g_hash_table_insert_node () from /usr/pkg/lib/
#5  0x00007f7ff1835823 in g_hash_table_insert_internal () from /usr/pkg/lib/
#6  0x00007f7ff183ccb1 in g_key_file_flush_parse_buffer () from /usr/pkg/lib/
#7  0x00007f7ff183cf62 in g_key_file_parse_data () from /usr/pkg/lib/
#8  0x00007f7ff183d0e1 in g_key_file_load_from_fd () from /usr/pkg/lib/
#9  0x00007f7ff183d99e in g_key_file_load_from_file () from /usr/pkg/lib/
#10 0x0000000000405532 in _start ()
Apart from these programmes I receive SIGILL in mplayer when trying to play videos. Backtrace doesn't tell anything useful.

sxiv, an image viewer, segfaults with this:
#0  0x00007f7ff64b209f in ?? () from /usr/lib/
#1  0x00007f7ff64b3983 in free () from /usr/lib/
#2  0x000000000040729c in remove_file ()
#3  0x0000000000409a92 in main ()
Previously, if built from local pkgsrc tree it worked but now stopped working at all at all.

mpg321 dumps core and says "Memory fault" with this backtrace:
#0  0x00007f7ff78068b1 in sem_post () from /usr/lib/
#1  0x000000000040afe0 in ?? ()
#2  0x0000000000403695 in ?? ()
#3  0x00007f7ff7ffa000 in ?? ()
#4  0x0000000000000002 in ?? ()
#5  0x00007f7ffffffdb0 in ?? ()
#6  0x00007f7ffffffdb7 in ?? ()
#7  0x0000000000000000 in ?? ()
I did memtests, once for four hours (two passes) and once for eight hours (eight passes). I did Dell's ePSA tests (diagnostic utility accessed from BIOS), it has own memtest, apart from monitoring the hard drive, the power supply, the keyboard, the fans, the CPU; all of them returned no errors. I rebuilt gtk2 with debug symbols but it changed nothing. On LQ it was suggested that I have hardware problems, but I am not convinced. Every programme described above worked inside Ubuntu LiveUSB
and Void Linux LiveUSB on the same machine (picked because they have different libc's). Before I had NetBSD with X11 a couple of months ago (and earlier) and I didn't have these errors. In the Interwebs
I found similar messages on Arch forum and Launchpad. Is there a need for a 24 hour memtest? Should I just remove each of the two memory modules and try? Is it hardware related after all?

Thanks everyone for any kind of help.
Reply With Quote