View Single Post
  #1   (View Single Post)  
Old 15th November 2009
mururoa mururoa is offline
Fdisk Soldier
 
Join Date: May 2008
Posts: 46
Default Mount smb in zfs tree

Hi there,

Now that I use 8.0 (RC3) I have a little problem with smb mounts.
I suspect that the problem is zfs related.
Here is my /etc/fstab :

# Device Mountpoint FStype Options Dump Pass#
/dev/ad8s2b none swap sw 0 0
/dev/ad8s2a /bootdir ufs rw 1 1
/dev/acd0 /cdrom cd9660 ro,noauto 0 0
/dev/acd1 /cdrom1 cd9660 ro,noauto 0 0
linproc /usr/compat/linux/proc linprocfs rw,late 0 0
//guest@ROUTEUR/nas /shares/stick smbfs rw,late 0 0

all is ok up to linproc (included) but when it comes to the smb share the boot process stops asking me to enter return for shell. So I press return, get the shell, do nothing, and then enter ^D to continue the boot. In the end the smb filesystem is mounted and all is working ok. If I remove the last line ofc there is no problem at all outside that I have to mount /shares/stick by hand.
All is using zfs on my system outside the /boot partition (inside /bootdir) and the swap so /shares/stick is on zfs but /usr/compat/linux/proc is on zfs too and it's ok with the late option for this one.
I tried to add extra_netfs_types="YES" in rc.conf but it didnt help either; this one should be for nfs.
What's the trick to get smb filesystems mounted inside zfs mount points ?

Last edited by mururoa; 15th November 2009 at 07:03 PM.
Reply With Quote