View Single Post
  #5   (View Single Post)  
Old 13th July 2009
IronForge IronForge is offline
Fdisk Soldier
Join Date: Jul 2009
Location: SoCal - "have skills, will travel for projects"
Posts: 55
Default Build Error on Xenocara

Thanks, ocicat:

Had a few reference pages up in addition to the Man pages.

I tried to make-install the ports. It failed overnight.

I did try the CVSROOT functions and update the src and ports that way. Still get the "w-pkgname" listings; but presume the upgrades went.

Rebuilt the Kernel and Binanries to follow -STABLE.

Tried to make build the Xenocara directory per Faq5 (checkout from anoncvs); but encountered Code1 Errors.

They are
/usr/xenorcara/lib/libdrm/intel (line 92 of /usr/share/mk/

# C
${LINK.c} -o ${.TARGET} ${.IMPSRC} ${LDLIBS}
${AR} ${ARFLAGS} $@ $*.o
rm -f $*.o

/usr/xenorcara/lib/libdrm (line 48 of /usr/share/mk/
.if !defined(BSD_OWN_MK) LINE 46
. include <> LINE 47
.endif LINE 48


.if !target(build)
.if exists(Makefile.bsd-wrapper)
_wrapper = -f Makefile.bsd-wrapper
cd ${.CURDIR} && exec ${MAKE} ${_wrapper} cleandir LINE 203
cd ${.CURDIR} && exec ${MAKE} ${_wrapper} depend
cd ${.CURDIR} && exec ${MAKE} ${_wrapper} all
cd ${.CURDIR} && exec ${SUDO} ${MAKE} ${_wrapper} install

/usr/xenorcara/lib (line 48 of /usr/share/mk/
per above
/usr/xenorcara (line 48 of /usr/share/mk/
per above

Should I ignore this error? Can't find any error logs for xenocara builds; and There's no Bug buddy (still in a GDM/FVWM hybrid mode.)

Pls advise. Thanks.
Reply With Quote