View Single Post
  #2   (View Single Post)  
Old 23rd March 2020
Sensucht94's Avatar
Sensucht94 Sensucht94 is offline
Real Name: Paolo Vincenzo Olivo
Shell Scout
 
Join Date: Oct 2017
Location: Rome
Posts: 97
Default

Quote:
Originally Posted by notooth View Post
I got this error when building X11/xf86-video-intel on NetBSD 8.1. Can anyone help?]
Similar threads appear on this forum once in a while and the answer is always the same. If you planned to build any of the packages from the modular Xorg tree, you'd have to compile all the needed build/runtime dependencies from pkgsrc first as well, otherwise chances are high that mismatches among shared objects and missing headers willl prevent you from compiling packages or worse, that you'll end up having to work out a dependency hell. In order to properly build dependencies and link everything against the version found in pkgsrc, you ought to set at least:
Code:
X11_TYPE=modular
PREFER_PKGSRC?=yes
inside /etc/mk.conf.
Notice that in this particular case you're most likely missing x11/libxcb from pkgsrc
__________________
“Mi casa tendrá dos piernas y mis sueños no tendrán fronteras„
Reply With Quote