View Single Post
  #1   (View Single Post)  
Old 20th May 2008
Ofloo Ofloo is offline
Port Guard
Join Date: May 2008
Posts: 10
Default FreeBSD6.3 upgrade to FreeBSD7.0

Typed make update in /usr/src to have cvsup update the directory, .. i copied the GENERIC kernel file to a new one and edited that, .. then i typed config <kernelfile> ..? Weird no such command .. checked /usr/sbin config was there though only rw mode chmod +x .. didn't work checked what was in the config file apparently it was some script so: "cd /usr/src/usr.sbin/config && make install"

ERROR: version of config(8) does not match kernel!
config version = 600003, version required = 600004

Make sure that /usr/src/usr.sbin/config is in sync
with your /usr/src/sys and install a new config binary
before trying this again.

If running the new config fails check your config
file against the GENERIC or LINT config files for
changes in config syntax, or option/device naming

Figured it's due the freebsd7 source tree, so i downloaded with cvsup freebsd6.3 source tree still the same, how can i fix this ?

I have noticed that i still can compile when the configuration and src tree is FreeBSD6, though after reinstalling world and upgrading the kernel to 6.3p2 i still have this issue with config, when i try to compile a freebsd7 kernel, i've tried building world before using config without any effects ..
Reply With Quote