View Single Post
  #2   (View Single Post)  
Old 14th October 2018
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 7,417
Default

Quote:
...Install will tell me if the target system can or can not use Upgrade...
I've never seen this.

You can upgrade continuously, there is no harm in upgrading from older releases as long as you upgrade in sequence, and make all manual changes as recommended in each Upgrade Guide. So you could upgrade from 5.9 -> 6.0 -> 6.1 -> 6.2 -> 6.4 -> 6.5 -> 6.6.....

If you are curious, inspect your /usr/lib/libc.so.* files.
  • At 6.3-release, libc was at 92.3.
  • At 6.2-release, libc was at 90.0
  • At 6.1-release, libc was at 89.3
  • At 6.0-release, libc was at 88.0
This laptop I'm replying from began with a fresh install at 6.0. I have a couple of servers in production which began life as installs of 5.7. Unfortunately, I don't have any systems still in use that have been continuously upgraded from when I began with 3.3, but if I still had the hardware, they'd probably still have old libraries.
Reply With Quote