View Single Post
  #1   (View Single Post)  
Old 9th August 2011
kiimao's Avatar
kiimao kiimao is offline
Port Guard
Join Date: Aug 2011
Posts: 12
Default Problem installing 2nd nekwork card


I'm trying to setup an old laptop as an general purpose home server (gateway, torrent seedbox, wireless access point and whatever else I can think of adding).

I have added a second network card to the PC Card slot of the laptop, and OpenBSD recognises it as "Realtech 8139" and assigns it device name "rl1".
But when I try to run dhclient on it it keeps timing out waiting for a reply, and the error message:
rl1: watchdog timeout
keeps popping up on the console.

Googling this suggests that it might be solved disableing ASPI. But neither disableing ASPI or APM in the kernel makes any difference.

The card works fine when I tried it on the same machine useing a Linux live-CD I had lying around. And there doesn't seem to be any problem with the driver in OBSD since the same one is used for the built in ethernet card that works fine.

First time useing any flavor *BSD so I'm not sure what to try next.
Reply With Quote