View Single Post
  #4   (View Single Post)  
Old 17th August 2012
jggimi's Avatar
jggimi jggimi is online now
More noise than signal
Join Date: May 2008
Location: USA
Posts: 6,421

My best guess is that Splix failed to open a file, not a device. I guessed the spool file. But its just a guess. I don't use CUPS, and I've never used Splix.

I do not understand why you found it necessary to disable ulpt(4). I've done so with some multifunction printers in order to do things like use their scanners. Is it needed?

I also don't understand why you touched any ownerships or permissions in /dev. My thought was the permissions problem was with a spool file, not the device (which is managed by CUPS, not by the Splix filter, to the best of my understanding). You should be able to easily revert your /dev settings to their defaults by using the MAKEDEV tool. eg:
# cd /dev; sh MAKEDEV all

A search of the ports@ mailing list only had one short conversation about Splix, unassociated with your problem.

I recommend you post to ports@ with your problem description as you have done here. The Splix port maintainer is Antoine Jacoutot (ajacoutot@), he is active on the ports@ mailing list or you may contact him directly.
Reply With Quote