View Single Post
  #2   (View Single Post)  
Old 29th August 2016
ibara's Avatar
ibara ibara is offline
Future Defcon 201 speaker
 
Join Date: Jan 2014
Posts: 631
Default

That's how the install(1) program on NetBSD informs you that it doesn't accept long options (options that begin with --).

Besides, the --strip-program=strip flag is useless on the BSDs. That's almost certainly a Solaris or AIX (maybe HP-UX) compat thing. You should just delete it in your Makefile (probably more accurately in CMakeLists.txt).

I'm rather surprised that you say this works on OpenBSD. It shouldn't. OpenBSD's install(1) also lacks longopt support. I don't know about FreeBSD. I wonder if CMake checks for FreeBSD and OpenBSD and removes the flag. Then you should add NetBSD to that check.

Anyhow, simply remove the --strip-program=strip part of the command from your Makefile and it'll work.
Reply With Quote