View Single Post
  #3   (View Single Post)  
Old 4th September 2008
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 6,974
Default

Device numbers are assigned in order, during startup probe. When you installed the OS, you only had a single drive, it was assigned drive #0. You have since added two new drives ... but they are on the first IDE channel, and are found by the probe first. They are assigned drive #0 and #1, now, and your original drive is drive #2 (wd2). From my perspective, you have three choices:
  1. Move cables, and make your original drive the master of the first IDE channel, so it is assigned drive #0 again. You will need to change the boot sequence in your BIOS to match, of course.
  2. Boot in single user mode and edit /etc/fstab, changing all wd0 references to wd2.
  3. Give up and reinstall.
I'd recommend either option 1 or option 2.
Reply With Quote