View Single Post
Old 27th August 2010
BSDfan666 BSDfan666 is offline
Real Name: N/A, this is the interweb.
Helpful companion
 
Join Date: Apr 2008
Location: Ontario, Canada
Posts: 2,223
Default

If a package was looking for an older library, then that package was out of date, this happens as the packages aren't built at the same time as snapshots so you often need to use the ports tree yourself when following them.

The major number of a library version is cranked whenever an incompatible change is made, and programs need to be relinked, 13.0->13.1 is safe, 13.0->14.0 is not.

The nawk change is recent, awk is no longer linked to nawk in -CURRENT.
http://marc.info/?l=openbsd-cvs&m=128276412305891&w=2
http://marc.info/?l=openbsd-cvs&m=128285071411286&w=2
Reply With Quote