View Single Post
  #1   (View Single Post)  
Old 15th February 2013
tsarpal tsarpal is offline
New User
Join Date: Feb 2013
Posts: 2
Default bwi0 on Powerbook G4 crashes

Hi all, this is my first post here, so I please bare with me as I am learning the etiquette.

I recently installed OpenBSD 5.2 macppc on an Apple Powerbook G4. I can provide more info if needed but as a starting point, the bwi driver never worked for me and crashes every time I try to configure the card, continued blue lines.

It seems fine in the dmesg and I can actually "see" the interface as bwi0 with ifconfig but when I try to configure it, it just crashes and only way out is a power cycle.

I think other people had the same problem too but cannot seem to find a clear answer if it is a hardware or software issue, however I did run the hardware diagnostics that come with the Apple CD (OK) and the card seems to work fine under Mac OS X so I am guessing there's someting wrong with the firmware for the card.

I also tried other versions of the bwi firmware from but to no avail.

I would appreciate any pointers on this.

Last edited by tsarpal; 15th February 2013 at 09:47 AM.
Reply With Quote