View Single Post
  #1   (View Single Post)  
Old 12th May 2008
bjstick bjstick is offline
New User
Join Date: May 2008
Posts: 4
Default Strange FreeBSD Issues (USB/Nvidia Drivers)

I have used FreeBSD in the past with no problems. I tried it out around 4.2, and used it as a primary desktop OS after Nvidia released their first GLX drivers. I tried revisiting it recently, and it is giving me nothing but trouble. See below:

1) When booting, if there is a USB hard drive attached I get an instant kernel panic right after it is detected.

2) I can unplug my USB drive and the system will boot. However, during boot my other USB devices (mouse/keyboard) drop connection and I have to unplug them and plug them back in to have them reactivate.

3) NVidia driver does not work for me. I was able to boot into X using "nv" driver, but when I compiled nvidia-driver from ports and ran nvidia-xconfig, I get an error about "/dev/nvidiactl" not being found and X will not boot.

This was with 7.0-RELEASE. The same problems persist with PC-BSD 1.5.1 which is based on 6.3-RELEASE. In fact, when I select the "nvidia" driver during the initial boot, my system hard locks when testing the screen. I have no problems with Linux on this computer, and even Solaris works perfectly with the NVidia drivers and all attached USB devices. Also, I am able to run "special" versions of OS X Leopard with no problems on this machine. Only FreeBSD gives me these problems. OpenBSD boots up normally.

My system specs are:

Gigabyte GA-EX38-DS4 Motherboard
Intel E6850 Core2Duo
XFX NVidia 8800 320MB GTS (G80)
4GB GeiL PC6400 DDR2
150GB WD Raptor

AHCI/SATA Native mode are enabled in BIOS.

Anybody have any ideas?
Reply With Quote