View Single Post
  #8   (View Single Post)  
Old 7th April 2010
Broodjegehaktmetmayo Broodjegehaktmetmayo is offline
Shell Scout
Join Date: Sep 2008
Posts: 92

Originally Posted by Broodjegehaktmetmayo View Post
Thank you very much for your helpfull response

I decided your reasoning about the dangers of having anything else than Windows write on ntfs makes sense, so I decided to go with your recommendation.

That didn't exactly work out

I created /mnt/xp1, xp2, xp3 and xp4, and added this to /etc/fstab:

/dev/ad6s5             /mnt/xp1        ntfs    ro              0       0
/dev/ad6s6             /mnt/xp2        ntfs    ro              0       0
/dev/ad6s7             /mnt/xp3        ntfs    ro              0       0
/dev/ad6s8             /mnt/xp4        ntfs    ro              0       0
And rebooted.

Which gave me during the intial startup:

Mounting /etc/fstab filesystems failed, startup aborted.

ERROR: ABORTING BOOT (sending SIGTERM to parent)!

/bin/sh on /etc/rc terminated abnormally, going to single user mode
This is where I completely reinstalled FreeBSD in order to try again ().

(No, seriously, if I hadn't learned about mount -u / and mount -a before I would have done that since in single user mode there is no way you can edit /etc/fstab if you don't first do that - at least I learned something ).

So I am wondering if there is something else I need to customize somewhere else in order to make the boot go right, or

I will start investigating this, but thanks again for your help; I really do appreciate it (!)

So I have all these settings in fstab I made earlier commented out (#), now I am downloading a pdf, it asks me where to save, I browse around and to my surprise all my ntfs-drives have been mounted already (), and come to think of it, they have been mounted even before I tried the entries in fstab (I just didn't realize it as for example, in my /home/ I have a folder 'Downloads' and under XP I also have a partition 'Downloads'. So I saw 'Downloads' but didn't realize this wasn't the one in my /home/ but instead an XP-partition.

FreeBSD 8.0 automatically mounts ntfs-partitions
Reply With Quote