View Single Post
  #1   (View Single Post)  
Old 6th June 2018
puffymon puffymon is offline
Real Name: Leonid
Port Guard
Join Date: Apr 2017
Location: Earth
Posts: 37
Default FreeBSD as sndio host


By reading sndiod(8) (and OpenBSD FAQ), starting it as:
# sndiod -L-
is enough to permit remote connections, but that's not true at FreeBSD.

If I use -L flag, I get two problems at once: remote machines are unable to use snd@myhostname/0 and rsnd@myhostname/0 devices and host machine is unable to use snd/0 and rsnd/0 devices, my host machine is muted!
(not globally, only applications which use sndio are muted, applications using other backends are not muted)
mazocomp$ uname -a
OpenBSD mazocomp.lan 6.3 GENERIC.MP#47 amd64
Reply With Quote