View Single Post
  #2   (View Single Post)  
Old 3rd February 2019
Sensucht94's Avatar
Sensucht94 Sensucht94 is offline
Real Name: Paolo Vincenzo Olivo
Fdisk Soldier
 
Join Date: Oct 2017
Location: Rome
Posts: 69
Default

Hadn't noticed that thread, so here's a month late reply, probably useless, but possibly worth something:

If you're going to use modular Xorg, then you'll need to tell pkgsrc to use /usr/pkg/*instead of /usr/X11R7/* as PREFIX, which will set /usr/pkg/lib as LD_LIBRARY_PATH, etc....for all packages requiring X11 shared objects and headers. This can be accomplished by appending:

Code:
X11_TYPE=modular
to your /etc/mk.conf. If you hadn't done this in the first place, before compiling everytthing else, then this would account for all the unmet X11 runtime requirements mentioned in the error log you posted above

If you set X11_TYPE=modular right now, you'll likely have to recompile most packages either way, so it would be advisable to delete all packages and start over.

Quote:
Originally Posted by KenJackson
It fails trying to build dependency modular-xorg-xephyr looking for dependency dri. I can't find it with pkgin nor in pkgsrc.
[Mesa 3D] DRI is provided by graphics/MesaLib18 compiled with 'dri' build option

Hope this helps
__________________
Be the change you want to see in the World
Reply With Quote