View Single Post
Old 9th May 2008
kienjakenobi's Avatar
kienjakenobi kienjakenobi is offline
Join Date: Apr 2008
Posts: 57

Originally Posted by DrJ
You missed the point. An LCD looks good only when it runs at its native resolution (or perhaps an integer fraction thereof). It really does look terrible otherwise. Your issue is that you have to adjust how things are rendered (like character sizes) given your monitor's resolution. All of that can be changed to what you like.
I wonder, what is your definition of "resolution" here? There is a set number of physical pixels in an LCD monitor. It is possible to run a "soft" (Dictated by X) resolution that matches the physical number of pixels in the monitor, but in my experience this does not necessarily make things look better. However, I do agree that it is necessary to keep the "soft" resolution in proportion with the physical monitor's resolution. This is probably what seadog109 has been using the entire time in Windows, so this is all he needs to do in FreeBSD.

To seadog109:

Originally Posted by seadog109
im on DesktopBSD btw
This means this post should be in Other Operating Systems ---> Other BSD
I will move it there now.

Originally Posted by seadog109
so you can imagine how upset at how many disks ive lost
You should not have lost any disks due to using many versions of Linux, BSD, or Windows on the same hard drive. I have used more versions of Linux than that + Windows XP + BSD on the exact same hard drive without any ill effects.

However, to fix your resolution problem:
  • Log in as root.
  • If you are unable to log in as root, then press Alt+F2 in KDE. Type "su kedit" This should open kedit with root authority.
  • Now open /etc/X11/xorg.conf
  • If you still see nothing in this file, you should run "Xorg -config" in a terminal with root authority.
  • If you do see something in your xorg.conf file now, go to the section titled "Display" and edit this line:
  • Modes "1024x768"
  • See the post below by robbak for more information.

Originally Posted by seadog109
im running as nVidia Ge-Force 7600GS on a 19'' Flat LCD
Do you have the nVidia graphics driver installed? I highly recommend this. This could even make your resolution problem much easier to control. Rather than following the directions above, do this:

  • In a terminal with root authority:
  • *cd /usr/ports/x11/nvidia-driver
  • make install clean
  • cd /usr/ports/x11/nvidia-settings
  • make install clean
  • cd /usr/ports/x11/nvidia-xconfig
  • make install clean
  • nvidia-xconfig (Still inside the terminal)
  • Now, inside KDE, you should have in the K Menu a NVIDIA control panel where you can change the resolution pretty easily.

*I have never used DesktopBSD, so please correct me if it installs software differently than FreeBSD.
Reply With Quote