View Single Post
Old 11th February 2009
jggimi's Avatar
jggimi jggimi is offline
More noise than signal
 
Join Date: May 2008
Location: USA
Posts: 5,972
Default

OK, now I have an idea of why cardbus0 and ath0 aren't enabled when using ACPI. There is a problem with bus enumeration from the hardware.

A quick peek at the source code for cbb(4) found this comment above the kernel message in sys/dev/pci/pccbb.c:
Quote:
/*
* When bus number isn't set correctly, give up using 32-bit CardBus
* mode.
*/
if (((busreg >> 8) & 0xff) == 0) {
printf(", CardBus support disabled");
sc->sc_pcmcia_flags |= PCCBB_PCMCIA_16BITONLY;
}

printf("\n");
There have been two patches to this module since 4.4 in -current, neither apply in this area.

------------

Thank you for the vendor download link!

BIOS Version:

It's possible a more up-to-date BIOS may help. The September '04 BIOS addresses what look like several ACPI issues, though none of the newer releases appear to do so. I would flash the most recent BIOS, which is four years old.

BIOS Settings:

Looking through the BIOS settings in Chapter 2 of the manual, it appears there is a "Load Optimized Defaults" setting, but no alternative "Load Safe Defaults" -- which I would have recommended, if such a setting existed. There is a "High Performance Mode" which you might consider disabling, just to see if it makes a difference.

Additional thoughts:

Your PC does not appear in the OpenBSD Project's i386-laptop page -- but if you examine it (www.openbsd.org/i386-laptop.html) you can see what problems other laptops with similar hardware have had.

Your specific model has never had mention in misc@, nor in any bug report.
Reply With Quote