View Single Post
  #1   (View Single Post)  
Old 9th May 2018
BSD-user BSD-user is offline
New User
Join Date: Mar 2015
Posts: 9
Default [SOLVED] Can't get NetBSD off the ground (install woes)

I'm having a really tough time getting NetBSD installed. I consider myself an avid GNU/Linux user but I was interested in decentralising a bit due to potential issues and policy questions related to the Linux kernel (long story perhaps for another time).

Here is the partition layout I've been trying to implement with my install. This is in both MBR and UEFI cases.

|_ / (80GB, FFS)
|_ /boot/efi (2MB, msdos)
|_ cgd (remainder)
____|_ swap (16GB)
____|_ /var (1GB)
____|_ /home (remainder)

In the installer program I choose extended partitioning to set it up like this. I keep getting errors.

(1) In the MBR case I tried leaving 1MB of free space from start of the disk to the start of / partition. The installer then installs without error but the system doesn't boot. I already set wd0 as bootable.

(2) In the UEFI case (my preferred) I changed the partition layout to GPT and proceeded to mimic the layout above but I keep getting errors in the process when saving the layout. I get an immediate error after the first attempt at setting the crypto password. Is there some issue with using CGD and GPT?? Second where should the efi partition (formatted FAT) be mounted? I'm only guessing that it's /boot/efi.

Last edited by BSD-user; 10th May 2018 at 11:19 PM.
Reply With Quote