View Single Post
Old 18th August 2015
GarryR's Avatar
GarryR GarryR is offline
Real Name: Garry Ricketson
Spam Deminer
 
Join Date: Jul 2015
Location: Durango, Mx.
Posts: 297
Default Still no connect, sort of a "review"

Quote:
Then I ran out of "air time", so I need to re-charge the account, I just put 50 pesos,
Well now, I have a "month" or full 3gb, which ever gets used first,...any way, I made the changes to my /etc/ppp/peers/telcel and, at least I don't get any "error" messages, when I run :
Code:
 pppd call telcel
but still no connect.
-----------------------------
I copied all the files, in the ppp directory, and made another
"ifconfig2.txt" :
Code:
$ifconfig 
	inet 127.0.0.1 netmask 0xff000000
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	media: Ethernet autoselect (none)
	status: no carrier
enc0: flags=0<>
	priority: 0
	groups: enc
	status: active
vlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	lladdr 60:eb:69:0f:9b:26
	priority: 0
	vlan: 1 parent interface: re0
	groups: vlan
	status: no carrier
pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33192
	priority: 0
	groups: pflog
ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
	priority: 0
	groups: ppp egress
	inet 0.0.0.0 --> 10.64.64.64 netmask 0xffffff00
-------------------------------------------------------------------------------------------
This is the current /etc/ppp/peers/telcel:
Code:
 # the calling unit in /dev:
cuaU0
# baud rate
115200
# send debug information to /var/log/daemon
debug
# do not require the ISP to authenticate itself
noauth
#  use this connection for the default route
:10.64.64.64
ipcp-accept-remote
defaultroute
# make this PPP connection when packets are outgoing, disconnect 
# when idle 5 minutes.  If ntpd(8) is running, ignore its clock synchronization
# packets for idle calculations. 
demand
idle 600 
active-filter 'not udp port 123' 
# don't shutdown if the connection goes idle
persist
# userid for PAP authentication
user webgprs# modem commands to be sent when connecting
connect "/usr/sbin/chat -v -f /etc/ppp/telcel-chat"
--------------------------------------------
Next, the:
/etc/ppp/telcel-chat
Code:
# time out if no responses after 10 seconds
TIMEOUT 10
# report if connected
REPORT CONNECT
# terminate the script if the modem is busy, has no data link, or has an error
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
# reset the modem, load factory defaults
'' ATZ OK AT&F OK
# define GPRS core network as the context, 
# see https://en.wikipedia.org/wiki/Hayes_command_set
AT+CGDCONT=1,"10.64.64.64""internet.itelcel.com" OK
# dial 
ATD*99# CONNECT
---------------------------------------------------
/etc/ppp/options
Code:
#       $OpenBSD: options.sample,v 1.2 2014/07/10 11:18:23 jasper Exp $
/dev/cuaU0
19200
modem
crtscts
defaultroute
netmask 255.255.255.0
ipcp-accept-local
ipcp-accept-remote
noipdefault
lock
connect "/usr/sbin/chat -v -f /etc/ppp/telcel-chat"
-----------------------------------------------------------------------------
last ( I think )
/etc/ppp/chap-secrets
Code:
 # Secrets for authentication using PAP
#client       server     secret      IPaddresses
webgprs      *       webgprs2002
??? Perhaps I need the "remote IP here ? or which IP address ???
------------------------------------------------------
Ahh , Ok, well I think I maybe have just found the problem there is another file in the
ppp directory, that I did nothing with, named "pap-secrets"
pap-secrets
Code:
 #	$OpenBSD: pap-secrets,v 1.3 2002/06/09 06:15:15 todd Exp $

# Secrets for authentication using PAP
# client	server	secret			IP addresses
-----------------------------------------------------------------------------------------

I wonder, if it is looking for "pap-secrets" instead of "chap-secrets" or it needs both,..that is easy enough to try,.
I do know for sure if the ISP or modem does not get the password, it will not connect, sometimes something occurs on Debian Jessie, and the password is not saved by network manager,correctly, So I get prompted, by the "keyring" thing, asking for it, and if I don't enter it, or make a typo, it will not connect.
I did not think of this , but maybe ,
Quote:
# send debug information to /var/log/daemon
maybe there is some info in the daemon now,...
Thank you very much, again, ...
Reply With Quote