View Single Post
  #1   (View Single Post)  
Old 26th September 2010
granowski granowski is offline
New User
Join Date: Sep 2010
Posts: 1
Default Atheros Wifi NetBSD on a Sparc64

Hello BSD-community,

Excuse me if this post has been previously answered, and when it is so, I would love the redirection.

I have a Sun Microsystems Ultra 60 Creator 3D computer that is running NetBSD 5.0.2. I have installed a simple PCI wireless card that has an Atheros chipset, so the system recognizes ath0. I'm tried manipulating the options with ifconfig and wpa_supplicant to get the network card to connect to my router. I've tried just about everything I can think of plus reading other similiar issues online.

After running wpa_supplicant with the following line:
wpa_supplicant -i ath0 -c /etc/wpa_supplicant.conf -B
it says "Bus error (core dumped)"

Running the same command except with option "-d": Tells me it runs up to the end of my wpa_supplicant.conf file but fails when it finishes reading and trys "initializing interface (2) 'ath0'"

Could this be because I'm insane for trying to run a normal PCI wireless card in a Sun Sparc64 Workstation? :\
Reply With Quote