Thread: Virtual Machine
View Single Post
  #3   (View Single Post)  
Old 7th May 2019
J65nko J65nko is offline
Administrator
 
Join Date: May 2008
Location: Budel - the Netherlands
Posts: 3,588
Default

In my VM I have:
Code:
vm_j65# cat /etc/resolv.conf
# Generated by vio0 dhclient
nameserver 100.64.1.2
lookup file bind
To see whether you are right I commented out that second line, but after I reloaded the rules of my desktop hosting the VM, the VM could not resolve anymore:
Code:
vm_j65# dig www.google.com          

; <<>> DiG 9.4.2-P2 <<>> www.google.com
;; global options:  printcmd
;; connection timed out; no servers could be reached
However if I specify a name server it does:
Code:
vm_j65# dig www.google.com @8.8.8.8

; <<>> DiG 9.4.2-P2 <<>> www.google.com @8.8.8.8
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10672
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.google.com.                        IN      A

;; ANSWER SECTION:
www.google.com.         6       IN      A       172.217.168.228

;; Query time: 10 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue May  7 22:47:59 2019
;; MSG SIZE  rcvd: 48
So I think I really need that line .....
You may not need it because, I assume, you speifically configured your VMs to use the Quad9 name servers instead of the default OpenBSD VM on 100.64.1.2 that I have.
__________________
You don't need to be a genius to debug a pf.conf firewall ruleset, you just need the guts to run tcpdump
Reply With Quote