View Single Post
  #1   (View Single Post)  
Old 13th September 2019
sacerdos_daemonis's Avatar
sacerdos_daemonis sacerdos_daemonis is offline
Real Name: Will forever be a secret.
Spam Deminer
Join Date: Sep 2014
Posts: 266
Default unble to input with Ibus and SCIM

I am new to FreeBSD and am in the process of getting accustomed to it. I have tried both Ibus and SCIM with FreeBSD 12, but neither will input Chinese. I can add input methods, but cannot use them.

Ibus' directions say:
export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
to ~/bshrc
I have an .shrc and .cshrc. I tried adding those entries to one, then the other, and even created a .bshrc.

SCIM's directions say:
Remember to set environment variable XMODIFIERS:
  csh/tcsh: setenv XMODIFIERS @im=SCIM
  sh/bash:  export XMODIFIERS='@im=SCIM'
and set LANG, LC_CTYPE to one of the following values:
  Traditional Chinese:
    zh_TW.UTF-8, zh_TW.Big5
    zh_HK.UTF-8, zh_HK.Big5-HKSCS
So my thought is the locale settings must be modified. I might be interpretting it incorrectly, but the Handbook directions for setting locales in ~/.login_conf and /etc/rc.conf appear to be for setting the user's language, not adding a language. I cannot even find the file with locale settings file to look at it. The setlocale man page says it is in /usr/share/locale, but I do not see it.

It is a small problem based on my inexperience with FreeBSD. I have figured out most of the system, but configuring input methods is a bit challenging.

I can search the FreeBSD forum, but not register to post any questions. I have tried to register with three browsers, but none of them display the captcha. So this is my only forum resource.
Reply With Quote