View Single Post
  #1   (View Single Post)  
Old 23rd October 2019
acampbell acampbell is offline
Real Name: Anthony Campbell
Shell Scout
Join Date: Sep 2014
Location: London, UK
Posts: 138
Default Can't preserve /home on reinstalling 6.6 release

I've just (re)installed 6.6 on a laptop. My previous /home was at /dev/wd0k.

While reinstalling, I told disklabel to modify /dev/wd0k. It didn't offer me the option not to mount the partition but I put "none" for the mount point, which seemed to work.

After rebooting I inserted a line in /etc/fstab:
/dev/wd0k /home ffs rw,nodev,no suid 1 2

This causes an error message on boot:
mount dev/wd0k on /home: Invalid argument

The same thing happens if I run the command manually.

I know this method of saving /home worked for me some time ago. Has something changed in 6.6 which prevents it working? Have I missed a step?

I can reconstitute /home if necessary without too much hassle (it's not my main computer) but I'd like to find out what's happening.
Reply With Quote