View Single Post
  #8   (View Single Post)  
Old 26th November 2017
philo_neo71 philo_neo71 is offline
Spam Deminer
 
Join Date: Jul 2009
Posts: 269
Default

hello,
I installed NetBSD 7.0.2 + patch i386 and pkgsrc2017Q3 for i386,
I had problems with the pkgin package manager, to install an Xfce4 desktop.
I went into "mode" compilation and manually compile Xfce4,
with the manager xf86-video-vesa, I have a desktop that appears but it's not very user-friendly,
trying to install xf86-video-ati I meet this error that I can not get around.
here is my output

Code:
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking if RANDR is defined... yes
checking if RENDER is defined... yes
checking if XV is defined... yes
checking if DPMSExtension is defined... yes
checking for LIBDRM... no
configure: error: Package requirements (libdrm >= 2.4.78) were not met:

Package dependency requirement 'libdrm >= 2.4.78' could not be satisfied.
Package 'libdrm' has version '2.4.59', required version is '>= 2.4.78'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDRM_CFLAGS
and LIBDRM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
*** Error code 1

Stop.
make[1]: stopped in /usr/pkgsrc/x11/xf86-video-ati
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/x11/xf86-video-ati
hpc-meteo#
I chose to isolate the pkgsrc libdrm, but nothing to do it does not compile separately, I do not know what to do!

Regards
Philippe
Reply With Quote