View Single Post
  #6   (View Single Post)  
Old 6th April 2010
Broodjegehaktmetmayo Broodjegehaktmetmayo is offline
Shell Scout
Join Date: Sep 2008
Posts: 92

Originally Posted by Beastie View Post
/dev/ad10s1* are for FreeBSD; /dev/ad6s1 and /dev/ad6s2 must be primary NTFS partition or something; /dev/ad6s5 to /dev/ad6s8 are your logical partitions.

Even though many people use the fusefs NTFS implementation successfully, many have also experienced problems. I personally wouldn't trust anything but Windows to write on an NTFS partition. I'd use FreeBSD's ntfs module to access the partition as read-only. All it takes is a line such as /dev/ad6s5 /mnt/XYZ ntfs ro 0 0 in /etc/fstab, then you create the mount-point (mkdir /mnt/XYZ) and mount the partition (mount /mnt/XYZ). Of course you need the ntfs module loaded (kldload ntfs), or you can simply reboot and have the system load the module and mount the partition.

You can always backup your FreeBSD home directory and system settings on a FAT32 local partition or USB pendrive.
Thank you very much for your helpfull response

I decided your reasoning about the dangers of having anything else than Windows write on ntfs makes sense, so I decided to go with your recommendation.

That didn't exactly work out

I created /mnt/xp1, xp2, xp3 and xp4, and added this to /etc/fstab:

/dev/ad6s5             /mnt/xp1        ntfs    ro              0       0
/dev/ad6s6             /mnt/xp2        ntfs    ro              0       0
/dev/ad6s7             /mnt/xp3        ntfs    ro              0       0
/dev/ad6s8             /mnt/xp4        ntfs    ro              0       0
And rebooted.

Which gave me during the intial startup:

Mounting /etc/fstab filesystems failed, startup aborted.

ERROR: ABORTING BOOT (sending SIGTERM to parent)!

/bin/sh on /etc/rc terminated abnormally, going to single user mode
This is where I completely reinstalled FreeBSD in order to try again ().

(No, seriously, if I hadn't learned about mount -u / and mount -a before I would have done that since in single user mode there is no way you can edit /etc/fstab if you don't first do that - at least I learned something ).

So I am wondering if there is something else I need to customize somewhere else in order to make the boot go right, or

I will start investigating this, but thanks again for your help; I really do appreciate it (!)

Reply With Quote