View Single Post
  #3   (View Single Post)  
Old 12th January 2014
Atlantis Atlantis is offline
New User
Join Date: Jan 2014
Posts: 4

Hi jggimmi

Thanks for your time !

This is for automatic multipath routing. When set to 1 (equal), routes added with -mpath use equal cost multipath routing, and when set to 0 (not-equal), only the first path added with -mpath will be used. It is unclear how you are adding the route definitions, but if -mpath is not used with route(8), and you are using PF rules only, then the OS will not test the sysctl setting. Equal cost multipath routing is described and an example is shown in OpenBSD FAQ 6.14. You may find that example and/or the route testing methods there helpful.
Actually, i do both: mpath equal routing and PF policy routing (maybe the root cause ??)

Here is re0 hostname conf

inet description "Connexion Numericable"
!route add -mpath default
and rl0

inet description "Connexion Free"
!route add -mpath default
sysctl.conf contains a line to enable mpath in an equal routing behavior:

net.inet.ip.multipath=1 # 1=Enable IP multipath routing
I have another set of rules without optimizations, etc... and problem remains the same...
I also tried to modify the route priority to lower FREE default route compared to NC one. It works, but still several packet losses, for a reason i miss.

I would be helpful if one among you has already set up such a kind of conf (tried several ones found on the internet, but most use old school ruleset)
A bsd 5.4 ruleset i could adapt to my case would be helpful

Thanks again !

Last edited by Atlantis; 12th January 2014 at 03:23 PM.
Reply With Quote