View Single Post
  #1   (View Single Post)  
Old 16th May 2016
fvgit's Avatar
fvgit fvgit is offline
Tempvs fvgit
 
Join Date: May 2016
Location: perl -MMIME::Base64 -le 'print decode_base64("SGVyZSBiZSBkcmFnb25zC")'
Posts: 154
Default Can't boot after successful install of 5.9 amd64 on a macbook 4.1

Hello everyone,

another newcomer to the forum here, although I've been an on and off OpenBSD-user since at least version 2.6.

My OSX 10.5 installation is getting a bit long in the tooth so I decided to return to OpenBSD on the Desktop. As I'm in the middle of various projects I decided to take the dual-boot route, at least for the time being.

I've been trying to install 5.9 amd64 onto my macbook 4.1 for over a week now, without success. Basically the installation works fine until I try to reboot into the freshly installed system.

The steps I took are these:

0) At first and as a minimally invasive procedure to my existing OSX installation I attempted to install to a USB stick with refind on it, although without success. More precisely: the installation process finishes but booting the installed system fails.

After several failed attempts I gave up on that and decided to take the hard disk route:

1) Resize existing HFS+ partition to make space for a smallish OpenBSD partition (an adventure in itself, but in the end it worked)

2) Install from CDr (install59.iso amd64 platform). Works as expected and the installer seems more straightforward than ever. I basically took all the defaults, except for adding a test user.

3) Rebooting the machine after successfull installation fails somewhere at the second stage bootloader (cf.: http://www.openbsd.org/faq/faq14.html#BootAmd64).

The last screen output is (manually written down):

Code:
entry point at 0xf00100 [7205c766, 34000004, 24448b12, 20a304]
after that the screen goes black and nothing happens.



Some additional facts:
  • the OpenBSD partition is flagged A6 and bootable * and both the first and second stage bootloaders seem to have been installed (cf. http://www.openbsd.org/faq/faq4.html#InstProb)
  • the OpenBSD installer has successfully installed BOOTX32.EFI and BOOTX64.EFI to the small EFI partition under the directory /EFI/BOOT. At least I assume those are the OpenBSD files. When booting the mac and pressing the Option-Key (alt) a corresponding disc appears in the graphical UEFI boot menu which starts the OpenBSD bootloader when you click it.
  • booting /bsd.rd from disk instead of /bsd reboots the machine after the entry point, as opposed to the black screen mentioned above. Someone on misc@ seems to have had a similar problem with a pre-5.9 release kernel in January, but no follow-up messages were posted:
    http://marc.info/?l=openbsd-misc&m=145350181109130&w=2
  • for testing purposes I manually booted both the bsd and bsd.mp kernels directly from the installation cd by changing the default settings in the cd bootloader. Both kernels boot successfully until they find no init and then drop into the debugger, which is expected behaviour I suppose
  • I also tried installing a current snapshot (May 11th) with the same results
  • in an attempt to provide a dmesg I learned the hard way that the OpenBSD installer is apparently not equipped to distribute files (only retrieve them): sadly no mount capabilites for NFS shares or ftp put functionality. Therefore no dmesg, I'm afraid.


That's where I am right now. Are there any macbook-users out there with an older 4.1 machine (that's the early 2008 2.4 GHz Intel Core 2 Duo model) who succesfully installed OpenBSD 5.9? Please, tell me it's possible.

Any help any hints would be highly appreciated.

On a lighter note, there's also a silver lining: after all the failed attempts I almost know the OpenBSD installer by heart.
Reply With Quote