View Single Post
  #2   (View Single Post)  
Old 21st May 2016
fvgit's Avatar
fvgit fvgit is offline
Tempvs fvgit
 
Join Date: May 2016
Location: perl -MMIME::Base64 -le 'print decode_base64("SGVyZSBiZSBkcmFnb25zC")'
Posts: 152
Default

Still not able to boot the OpenBSD install. Just a follow-up with more details.

I finally managed to get a dmesg from the installer by booting from cd into (S)hell and mounting a dos-formatted USB stick to copy the output.

dmesg from booted install cd (May 11th snapshot)
Code:
OpenBSD 5.9-current (RAMDISK_CD) #1850: Wed May 11 11:46:44 MDT 2016
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/RAMDISK_CD
real mem = 2094206976 (1997MB)
avail mem = 2028949504 (1934MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0xe0000 (41 entries)
bios0: vendor Apple Inc. version "MB41.88Z.00C1.B00.0802091535" date 02/09/08
bios0: Apple Inc. MacBook4,1
acpi0 at bios0: rev 2
acpi0: tables DSDT FACP HPET APIC MCFG ASF! SBST ECDT SSDT SSDT SSDT SSDT SSDT
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz, 2394.42 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,NXE,LONG,LAHF,PERF,SENSOR
cpu0: 3MB 64b/line 8-way L2 cache
cpu0: apic clock running at 199MHz
cpu0: mwait min=64, max=64, C-substates=0.2.2.2.2.1.3, IBE
cpu at mainbus0: not configured
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
acpiec0 at acpi0
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 2 (RP05)
acpiprt2 at acpi0: bus 3 (RP06)
acpiprt3 at acpi0: bus 4 (PCIB)
acpicpu at acpi0 not configured
"ACPI0003" at acpi0 not configured
"PNP0C0D" at acpi0 not configured
"APP0002" at acpi0 not configured
"PNP0C0C" at acpi0 not configured
"PNP0C0E" at acpi0 not configured
"APP0001" at acpi0 not configured
"APP0003" at acpi0 not configured
"ACPI0002" at acpi0 not configured
"PNP0C0A" at acpi0 not configured
memory map conflict 0xf00f8000/0x1000
memory map conflict 0xfed1c000/0x4000
memory map conflict 0xfffa0000/0x30000
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel GM965 Host" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel GM965 Video" rev 0x03
wsdisplay1 at vga1 mux 1: console (80x25, vt100 emulation)
"Intel GM965 Video" rev 0x03 at pci0 dev 2 function 1 not configured
uhci0 at pci0 dev 26 function 0 "Intel 82801H USB" rev 0x04: apic 1 int 20
uhci1 at pci0 dev 26 function 1 "Intel 82801H USB" rev 0x04: apic 1 int 16
ehci0 at pci0 dev 26 function 7 "Intel 82801H USB" rev 0x04: apic 1 int 21
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
"Intel 82801H HD Audio" rev 0x04 at pci0 dev 27 function 0 not configured
ppb0 at pci0 dev 28 function 0 "Intel 82801H PCIE" rev 0x04: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 4 "Intel 82801H PCIE" rev 0x04: msi
pci2 at ppb1 bus 2
"Broadcom BCM4321" rev 0x03 at pci2 dev 0 function 0 not configured
ppb2 at pci0 dev 28 function 5 "Intel 82801H PCIE" rev 0x04: msi
pci3 at ppb2 bus 3
mskc0 at pci3 dev 0 function 0 "Marvell Yukon 88E8058" rev 0x13, Yukon-2 EC Ultra rev. B0 (0x3): apic 1 int 17
msk0 at mskc0 port A: address 00:1f:f3:d5:f7:57
eephy0 at msk0 phy 0: 88E1149 Gigabit PHY, rev. 1
uhci2 at pci0 dev 29 function 0 "Intel 82801H USB" rev 0x04: apic 1 int 16
uhci3 at pci0 dev 29 function 1 "Intel 82801H USB" rev 0x04: apic 1 int 18
uhci4 at pci0 dev 29 function 2 "Intel 82801H USB" rev 0x04: apic 1 int 21
ehci1 at pci0 dev 29 function 7 "Intel 82801H USB" rev 0x04: apic 1 int 20
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb3 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xf4
pci4 at ppb3 bus 4
"AT&T/Lucent FW322 1394" rev 0x61 at pci4 dev 3 function 0 not configured
"Intel 82801HBM LPC" rev 0x04 at pci0 dev 31 function 0 not configured
pciide0 at pci0 dev 31 function 1 "Intel 82801HBM IDE" rev 0x04: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide0: using apic 1 int 21 for native-PCI interrupt
atapiscsi0 at pciide0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-R UJ-867, HB01> ATAPI 5/cdrom removable
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
pciide0: channel 1 disabled (no drives)
pciide1 at pci0 dev 31 function 2 "Intel 82801HBM SATA" rev 0x04: DMA, channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide1: using apic 1 int 18 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <Hitachi HTS542516K9SA00>
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 6
"Intel 82801H SMBus" rev 0x04 at pci0 dev 31 function 3 not configured
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at mainbus0
umass0 at uhub0 port 2 configuration 1 interface 0 "Kingston DataTraveler 3.0" rev 2.10/1.10 addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd0 at scsibus1 targ 1 lun 0: <Kingston, DataTraveler 3.0, PMAP> SCSI4 0/direct removable serial.09511666BFA109378511
sd0: 29568MB, 512 bytes/sector, 60555264 sectors
"Micron Built-in iSight" rev 2.00/1.84 addr 2 at uhub1 port 4 not configured
uhidev0 at uhub2 port 1 configuration 1 interface 0 "vendor 0x05ac product 0x1000" rev 2.00/19.65 addr 2
uhidev0: no input interrupt endpoint
uhidev1 at uhub6 port 1 configuration 1 interface 0 "Apple Computer, Inc. IR Receiver" rev 2.00/0.16 addr 2
uhidev1: iclass 3/0, 38 report ids
uhid at uhidev1 reportid 36 not configured
uhid at uhidev1 reportid 37 not configured
uhid at uhidev1 reportid 38 not configured
uhidev2 at uhub6 port 2 configuration 1 interface 0 "Apple Computer Apple Internal Keyboard / Trackpad" rev 2.00/0.07 addr 3
uhidev2: iclass 3/1
ukbd0 at uhidev2
wskbd0 at ukbd0: console keyboard, using wsdisplay1
uhidev3 at uhub6 port 2 configuration 1 interface 1 "Apple Computer Apple Internal Keyboard / Trackpad" rev 2.00/0.07 addr 3
uhidev3: iclass 3/1, 5 report ids
uhid at uhidev3 reportid 2 not configured
uhid at uhidev3 reportid 5 not configured
uhidev4 at uhub6 port 2 configuration 1 interface 2 "Apple Computer Apple Internal Keyboard / Trackpad" rev 2.00/0.07 addr 3
uhidev4: iclass 3/0
uhid at uhidev4 not configured
softraid0 at root
scsibus2 at softraid0: 256 targets
root on rd0a swap on rd0b dump on rd0b
fdisk wd0 (from booted cd installer (S)hell as above)
Code:
Disk: wd0       Usable LBA: 34 to 312581774 [312581808 Sectors]
   #: type                                 [       start:         size ]
------------------------------------------------------------------------
   0: EFI Sys                              [          40:       409600 ]
   1: MacOS X HFS+                         [      409640:    289144832 ]
*  2: OpenBSD                              [   289816616:     22503008 ]
disklabel wd0 (from booted cd installer (S)hell as above)
Code:
# /dev/rwd0c:
type: ESDI
disk: ESDI/IDE disk
label: Hitachi HTS54251
duid: b7343e1a09520c97
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 19457
total sectors: 312581808
boundstart: 289816616
boundend: 312319624
drivedata: 0

16 partitions:
#                size           offset  fstype [fsize bsize  cpg]
  a:           554968        289816616  4.2BSD   2048 16384    1
  b:           946130        290371584    swap
  c:        312581808                0  unused
  d:           871552        291317728  4.2BSD   2048 16384    1
  e:          1180800        292189280  4.2BSD   2048 16384    1
  f:          2234336        293370080  4.2BSD   2048 16384    1
  g:          1283232        295604416  4.2BSD   2048 16384    1
  h:          4976576        296887648  4.2BSD   2048 16384    1
  i:           409600               40   MSDOS
  j:        289144832           409640     HFS
  k:          2253600        301864224  4.2BSD   2048 16384    1
  l:          2975296        304117824  4.2BSD   2048 16384    1
  m:          5226336        307093120  4.2BSD   2048 16384    1
And now some data from the OSX side:

fdisk /dev/disk0
Code:
Disk: /dev/disk0        geometry: 19457/255/63 [312581808 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE    0   0   2 - 1023  80  63 [         1 -  312581807] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

diskutil list
Code:
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *149.1 Gi   disk0
   1:                        EFI                         200.0 Mi   disk0s1
   2:                  Apple_HFS Macintosh HD            137.9 Gi   disk0s2
   3: 824CC7A0-36A8-11E3-890A-952519AD                         10.7 Gi    disk0s3
diskutil info disk0s3 (this is the OpenBSD installation target, created by resizing the existing HFS+ partition as described in my OP. I have no idea if this is relevant but the Not bootable remark as opposed to the OpenBSD fdisk wd0 output further above seems odd. )
Code:
Device Identifier:        disk0s3
   Device Node:              /dev/disk0s3
   Part Of Whole:            disk0
   Device / Media Name:      Untitled

   Volume Name:
   Mount Point:

   Partition Type:           824CC7A0-36A8-11E3-890A-952519AD3F61
   Bootable:                 Not bootable, can be made bootable safely
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified

   Total Size:               10.7 Gi (11521540096 B) (22503008 512-byte blocks)
   Free Space:               0.0 B (0 B) (0 512-byte blocks)

   Read Only:                No
   Ejectable:                No
   Whole:                    No
   Internal:                 Yes
And finally what I see when I try to boot OpenBSD from disk (written down by hand):
Code:
probing: pc0 mem[572K 64K 2007M 152K 224K 4M 416K 36K 20K 48K 28K 716K 288K 44K
40K 16K 88K 4M 28K 20K 236K 5M 3M 144K 40K]
disk hd0 hd1* hd2*
>> OpenBSD/amd64 EFIBOOT 3.30
boot> set
addr    0x0
howto
device  hd0a
tty     pc0
image   /bsd
timeout 0
db_console      unset
boot> boot
booting hd0a:/bsd.rd: 3345100+1411664+2413568+0+585728[72+439224+281972]= 0x8173f8
entry point at 0xf001000 [7205c766, 34000004, 24448b12, 9680a304]
Then the screen goes black (/bsd) or just nothing else happens (/bsd.rd) excpt for full throttle cpu fan.

Any ideas?
Reply With Quote