View Single Post
  #7   (View Single Post)  
Old 28th May 2016
fvgit's Avatar
fvgit fvgit is offline
Shell Scout
 
Join Date: May 2016
Location: perl -MMIME::Base64 -le 'print decode_base64("SGVyZSBiZSBkcmFnb25zC")'
Posts: 103
Default

Quote:
Originally Posted by jggimi View Post
Have you considered a second disk, to avoid multiboot configurations?
Actually my very first attempt at installing 5.9 was onto a USB device instead of the hard disk. I don't have an external USB hard drive, but given that I can't seem to boot anything from USB (nor hd for that matter) I doubt it'd make much of a difference. The only other alternative would be drive swapping. But even though this type of macbook is comparatively easy upgradeable (for an Apple machine), it is still necessary to remove the L-bracket behind the battery unscrew the hard drive from some kind of sled etc.etc. Might be my very last resort although it doesn't seem really practical and I'd have to buy a new drive. Somehow I don't think multi-booting is the problem as I can't even properly boot the miniroot*.fs images from USB.

Quote:
Originally Posted by NaWi View Post
In your open posting you wrote, that you use 10.5 but no details. The latest SMC version is 1.31f1 (SMC 1.4) https://support.apple.com/en-us/HT201518 which requires 10.5.8 to update.
Good catch! Yes, I do use 10.5.8 but my firmware was SMC version 1.31f0 (SMC 1.4). I installed the firmware upgrade this afternoon, but no change. FWIW, Apple just mentions better battery management in the accompanying support document: https://support.apple.com/kb/DL1312?locale=en_US

Quote:
Originally Posted by NaWi View Post
Have you tried the installation way for OpenBSD alone as I recommanded in the other topic ?
You mean Jasper's blog, right!? I had already come across that page looking for answers on the web. As I see it that information is superseded now. The 5.9 and higher installer does this by itself. The ESP already exists on the macbook and the new OpenBSD installer succesfully copies the corresponding *.EFI files in place.

Quote:
Originally Posted by NaWi View Post
Here is a Linux based description of hybride MBR's http://www.rodsbooks.com/gdisk/hybrid.html

As always, make a backup before you play around.
Thanks for that link covering hybrid MBRs! Seems pretty thorough, I'll have a good look at it.

After cleaning up the previous installation I repeated the install process twice today with the 5.9 snapshot (amd64) from the other day. Once on the separate OpenBSD partition (hard disk) and once on a dedicated USB device. Same result as always.
As it stands I'm unable to boot OpenBSD either from hard disk or attached USB device. The kernel always hangs at the entry point.

After poking around on misc@ I saw several similar problems mentioned when the EFI code was first introduced in 5.8-current around September 2015. I think the problem could be a bug in the EFI bootloader code. Maybe sth. like this: http://marc.info/?l=openbsd-misc&m=144233703211822&w=2
OpenBSD's EFI code is still fairly new and not even mentioned in the FAQ.
Reply With Quote