Thread: ping question
View Single Post
Old 14th November 2011
zealer zealer is offline
Port Guard
Join Date: Sep 2011
Posts: 10

Hi guys,

I ran into a problem. I did set up rdomain for one of the interfaces. Now ping to anywhere works from the desired interface. But there is a problem.
As i already mentioned, i have two interfaces connecting to two ISPs. Both are UP, but there is a problem: after i set one of the interfaces in rdomain1, i can no longer SSH to that address. SSH only works on the other interface, which is still in rdomain0. I tried even connecting from the BSD to itself on the problematic interface, i get an instant connection refused.
Problem is not in the ip address or in pf, as I tried reproducing on a VM here and got the same result (the interface that I set in rdomain1 is directly connected to PC) . Even with pfctl turned off, ssh session is sill refused.

no luck with my searches... rdomains are poorly documented. I read up the link referring to rdomain setup, but it did not help me with the ssh thing

I did found... something... that was pretty much my only 'finding': OBSD 4.7 release notes: Make it possible to set the rdomain in ssh(1)/sftp(1)/scp(1)/sshd(8)
There is nothing regarding rdomains in ssh man though, I couldnt find any more info about this

Any ideas?

Last edited by zealer; 14th November 2011 at 12:18 AM. Reason: add some info
Reply With Quote