View Single Post
  #1   (View Single Post)  
Old 21st November 2013
Jtf Jtf is offline
Port Guard
Join Date: Nov 2013
Posts: 17
Default FreeBSD won't boot after mounting root partition on OpenBSD

Hi all,

This is regarding a system that is dual booting FreeBSD and OpenBSD.
I have encountered a serious problem in which after mounting the root partition of my FreeBSD installation on OpenBSD (by accident), FreeBSD would not boot.

What I remembered doing in OpenBSD was trying to mount my usb partition (sd1i). I instead mounted sd0i which was my FreeBSD root partition and then I unmounted it. These where the commands on OpenBSD that I issued while doing that:

% # mount /dev/sd0i /mnt
% # cp –rf /mnt/
Pressed tab…
Saw the directory contents and realised that I mounted the wrong partition…
% # umount /dev/sd0i
And then mounted sd1i….

After that, I then tried to reboot to FreeBSD but the computer kept freezing up on this screen:

I have a feeling /boot/boot1 is the one that hanged but I'm not sure why and how to fix it. For dual booting, I am using FreeBSD’s /boot/boot0 boot manager.

The reason why I suspect mounting sd0i on OpenBSD to be the cause of the problem is because that was the operation I did to sd0i and that I was able to boot into FreeBSD previously before I booted into OpenBSD. I also don’t remember doing any operations involving partitions the last time I was on FreeBSD.

I tried googling for solutions to this but can’t find anyone with the same problem.

Something details that may be relevant:

FreeBSD 9.2 (generic kernel)

OpenBSD 5.4 (generic kernel)

ThinkPad T61 with a Seagate Momentus 5400.6 hard drive

Help would be appreciated. Thanks.

Last edited by Jtf; 21st November 2013 at 04:12 PM. Reason: Image is larger then 640x480
Reply With Quote